Current State of the Pyra


Magic Sam

Forever Homebrew
Joined
Aug 10, 2007
Messages
2,438
Age
39
Location
Penguin Village
Hi all,

Any news regarding the audio issues ? I tried to set the output volume down to ~50% but to no avail.

As soon as I start playing Serious Sam Second Encounter for example, audio issues kick in (loud static noise).

Exiting the game is the only way I found to make it stop.

Am I doing something wrong ?

Cheers, Magic Sam
 

levi

Still fresh, damnit!
Joined
Oct 6, 2008
Messages
15,001
Location
Somewhere off the coast of the EU
Any news regarding the audio issues ? I tried to set the output volume down to ~50% but to no avail.
Have you also muted the microphone inputs in alsamixer? I wonder also, how you set the game volume to 50%; is there a system app that sets some volume on some system or other, or did you use pavucontol or alsamixer for that?
 

Magic Sam

Forever Homebrew
Joined
Aug 10, 2007
Messages
2,438
Age
39
Location
Penguin Village
@EvilDragon : could you please tell me how to disable microphone input (I only found the mute check box in the sound preferences) ?

Nevermind @EvilDragon , I managed to disable microphone input with alsamixer :)

I'm afraid I don't have the technical skills required to work on the audio driver. Are there any other tasks in need of a system administrator ? I can write Bash scripts, and simple Python scripts too (not object oriented).

I'm willing to do my fair share of work, this is why I pre-pre-ordered :)

Cheers, Magic Sam
 
Last edited:

Magic Sam

Forever Homebrew
Joined
Aug 10, 2007
Messages
2,438
Age
39
Location
Penguin Village
Have you also muted the microphone inputs in alsamixer? I wonder also, how you set the game volume to 50%; is there a system app that sets some volume on some system or other, or did you use pavucontol or alsamixer for that?
I just left clicked on the speakers icon in the Mate taskbar, and lowered the output volume to ~50%. Alsamixer on the CLI reports the volume is down to 49%.

Cheers, Magic Sam
 

Magic Sam

Forever Homebrew
Joined
Aug 10, 2007
Messages
2,438
Age
39
Location
Penguin Village
Hi all,

Looks like the poor battery performance and the overheating issue (at least on my unit) are somehow related. I believe the system is drawing too much juice out of the battery, causing it to heat up.

Is my assumption correct-ish ?

Cheers, Magic Sam
 

EvilDragon

Administrator
Staff member
Joined
Mar 4, 2003
Messages
29,824
Age
44
Location
Ingolstadt
Nevermind @EvilDragon , I managed to disable microphone input with alsamixer :)

As mentioned before: this does not disable the audio stream for the microphone but only mutes it. This can improve things but not fix them.
Disabling the audio stream is only possible by poking a register of the Palmas Chip directly at the moment.
 

EvilDragon

Administrator
Staff member
Joined
Mar 4, 2003
Messages
29,824
Age
44
Location
Ingolstadt
eating issue (at least on my unit) are somehow related. I believe the system is drawing too much juice out of the battery, causing it to heat up.
Is my assumption correct-ish ?

Well, it could be that something is defective on your unit drawing more Power than it should.

You could try to let the unit sit around for an hour doing nothing (with keyboard brightness disabled and screen to lowest brightness so we have the same comparison base) to see how much the battery goes down during that time period.

Also, you can run htop to see if there's a suspicious program / task running that hogs the CPU.
(just don't run htop while doing the battery consumption test, as htop itself needs CPU time as well, so the comparison would be off)
 

levi

Still fresh, damnit!
Joined
Oct 6, 2008
Messages
15,001
Location
Somewhere off the coast of the EU
Plain old top only updates every three seconds rather than every second like htop does. It still uses some power, but a lot less.

If you want something that uses even less power then I suppose you could so something like: 'while true; do ps -ef --sort %cpu; sleep 10; done'. In fact if it's something regular then just doing the one 'ps -ef --sort cputime' might well show it
 

wismerhill

Still Fresh
Joined
Jun 18, 2017
Messages
21
Location
Belgium
Plain old top only updates every three seconds rather than every second like htop does. It still uses some power, but a lot less.
htop has a -d (--delay) option which allows you to tell how frequently you want it to update (see manpage for details).
 

levi

Still fresh, damnit!
Joined
Oct 6, 2008
Messages
15,001
Location
Somewhere off the coast of the EU
Yeah, htop's -d takes a number of tenths of a second to be it's update time. Top similarly has a -d option but the resolution of that argument is in seconds. But on my system, top with -d 3 uses 1% of CPU on average while htop with -d 30 uses 3.2%.
 

docbroke

Banned
Joined
Feb 21, 2019
Messages
590
Age
40
Location
India
Try this script, it displays process using max cpu and max memory, every 3 second.
Bash:
#!/bin/sh

cpu_sym=' '
mem_sym=' '
empty=

while :; do
    /bin/ps -eo %cpu,%mem,cmd \
    | awk -v prefix="$prefix" -v cpu_sym="$cpu_sym" -v mem_sym="$mem_sym" -v empty="$empty" '
        BEGIN { cpu_max = 1; mem_max = 1; }
        $1 > cpu_max { cpu_cmd = $3; cpu_max = $1; }
        $2 > mem_max { mem_cmd = $3; mem_max = $2; }
        END {
            print prefix cpu_sym, cpu_cmd, cpu_max, mem_sym, mem_cmd, mem_max
        }
    '
    sleep 3
done

Note: symbols used are from nerd fonts, if they are not displayed, you may need to use nerd font as your terminal font https://www.nerdfonts.com/
 

Magic Sam

Forever Homebrew
Joined
Aug 10, 2007
Messages
2,438
Age
39
Location
Penguin Village
Hi all,

@EvilDragon : OK I'll test my unit and report here ASAP.

EDIT: I charged the battery up to 72%, disabled the keyboard backlight and lowered the screen brightness to the lowest setting.

A simple Bash script is running in the background:

Code:
#!/bin/bash
while true ; do echo `date` ; sleep 60 ; done

Code:
./test.sh >> test.out 2>&1 &

This way we should have a rough estimate of how long the battery lasted.

Cheers, Magic Sam
 
Last edited:

Magic Sam

Forever Homebrew
Joined
Aug 10, 2007
Messages
2,438
Age
39
Location
Penguin Village
Hi all,

@EvilDragon : the results are in :)

First entry in test.out: Mon 6 Dec 17:34:57 CET 2021

Last entry: Tue 7 Dec 01:40:07 CET 2021

So the Pyra, sitting idle on the floor, went calmly from 72% to shutdown time in about 8 hours. If I'm not mistaken, Debian on the Pyra won't let the battery run completely out and make the system crash. Instead when the battery is low it'll properly shutdown to avoid any data loss. Similarly, it will refuse to fully boot if the battery is low, for the exact same reason. So there were certainly some battery left after those 8 hours...

Not too bad actually... I expected far worse results :D

Opinions ?

Cheers, Magic Sam
 
Top