Mounting Problems In Linux


Still Fresh
Jan 27, 2006
No matter what I do, I can't seem to get the GP2X to mount. I've tried everything I can think of, and I'm hoping someone has a suggestion to help my plight.

From dmesg
Initializing USB Mass Storage driver...
scsi2 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 4
usb-storage: waiting for device to settle before scanning
usbcore: registered new driver usb-storage
USB Mass Storage support registered.
Vendor: Linux Model: File-Stor Gadget Rev: 0229
Type: Direct-Access ANSI SCSI revision: 02
SCSI device sda: 2037010 512-byte hdwr sectors (1043 MB)
sda: assuming drive cache: write through
SCSI device sda: 2037010 512-byte hdwr sectors (1043 MB)
sda: assuming drive cache: write through
sda: unknown partition table
sd 2:0:0:0: Attached scsi disk sda
sd 2:0:0:0: Attached scsi generic sg0 type 0
usb-storage: device scan complete
usb 1-1: USB disconnect, address 4

# /etc/fstab: static file system information
# <file system> <dir> <type> <options> <dump> <pass>
none /dev/pts devpts defaults 0 0
none /dev/shm tmpfs defaults 0 0

/dev/sda /mnt/usb vfat rw, user, noauto 0 0
/dev/cdrom /mnt/cd iso9660 ro,user,noauto,unhide 0 0
/dev/dvd /mnt/dvd udf ro,user,noauto,unhide 0 0
/dev/fd0 /mnt/fl vfat user,noauto 0 0

/dev/hda1 swap swap defaults 0 0
/dev/hda2 / reiserfs defaults 0 0

but when I tell it to mount /dev/sda, I get
[mntent]: line 8 in /etc/fstab is bad
mount: can't find /dev/sda in /etc/fstab or /etc/mtab

My GP2X is 1.4.0 Firmware
The SD Card is properly formatted (I upgraded the fw with it, on an XP machine)
Batteries are fresh
Cable is good.

Why won't it work!? Blarghe!
it did, which was boneheaded of me, but even after that fix, I still get

mount /mnt/usb
mount: special device /dev/sda does not exist

Even when the cord is connected, and the GP2X is in USB Connected mode.
I still got nothing :-(
mount /dev/sda1
mount: special device /dev/sda1 does not exist
mount /mnt/usb
mount: special device /dev/sda1 does not exist

You can see how I'm all confused, nothing I'm trying is working!
I've tried all variants of sda :-(

And I reboot frequently, since I'm on a laptop.
Well, I tried something new....

from hwd:
USB : Acer Laboratories Inc. [ALi]|M5237 (USB) module: ohci_hcd

and I found i didn't have the ohci_hcd module in my config file. So I added it, and I'm getting an ALL NEW error message.

mount /dev/sda
mount: unknown filesystem type 'vfat'

Any ideas on this? Here's fstab's line again.

/dev/sda /mnt/usb vfat rw,user,noauto 0 0

(I know, /dev/sda ended up working. d'oh.)
Hmm, vfat is what I use for my fstab. You can try fat32 or fat16, but I doubt those'll work. Maybe try formatting the card again? cfdisk /dev/sda, and make it W95 FAT16. If needed, add a new (base) partition to the card.
I posed this problem to the forums for my distro (ArchLinux,) and they solved it.

all I had to do was enable MOD_AUTOLOAD="yes" in /etc/rc.conf (the AL confiure file.)

who woulda guessed?

oh well, thanks for the help everyone!