Problems with Firefox


Sigurd

Member
Joined
Nov 4, 2004
Messages
177
Hi guys, yet another stupid question from me today >.<


I cannot seem to get Firefox open. It worked earlier today.


I think it started when i tried to update Firefox via the PNDstore. I tried removing it fully and deleting the firefox folder in the appdata folder and "reinstalling the PND" both manually and via the PNDstore.


All i have to troubleshoot this problem with is the output from a dmesg:


[ 181.064208] aufs test_add:261:mount[2234]: uid/gid/perm /mnt/pnd/hdonk_firefox_001 0/0/0755, 0/0/0777


I'm running Super Zaxxon beta 5.


- Sigurd
 

Sigurd

Member
Joined
Nov 4, 2004
Messages
177
I already did, from repo.openpandora.org and via the PNDstore. when i try to open Firefox the sd access blink once and then no more. It's all very odd :/


EDIT: Just on a side note. Chrome opens and runs fine..
 
Last edited by a moderator:

Sigurd

Member
Joined
Nov 4, 2004
Messages
177
It's fairly huge. 60.2MB


EDIT: hmm.but the chromium PND is 54 ...
 
Last edited by a moderator:

sverm

Member
Joined
Aug 27, 2010
Messages
109
I don't see that as being a mounting problem necessarily. Can you try temporarily renaming your appdata folder for firebox, just in case there might be something gone wrong with that profile?
 

TangentDelta

Member
Joined
May 25, 2012
Messages
106
Location
United States
It's fairly huge. 60.2MB


EDIT: hmm.but the chromium PND is 54 ...
It's the right size. I was getting that same exact error you are getting, and I found out that my PND was only partially downloaded. My internet connection sucks :(
 
Last edited by a moderator:

Sigurd

Member
Joined
Nov 4, 2004
Messages
177
I don't see that as being a mounting problem necessarily. Can you try temporarily renaming your appdata folder for firebox, just in case there might be something gone wrong with that profile?

I tried completely removing it. But it has not been re-created.
 

MarioPandio

Well-Known Member
Joined
Aug 28, 2010
Messages
1,378
Location
Half way up the stair
If your problem is still not resolved.


Aswell as deleting the appdata folder, please try completely removing the FF.pnd file to a location outside of the pandora/ETC folder structure i.e remove it from desktop, or menu, or mmenu folders, to the root of your SD card. Hold R trigger and R key on the keyboard to trigger a refresh of the desktop, if that was where the pnd file was, or simply reboot. Then put FF.pnd back where you want it and try again and you may well find it works fine again.


Other things to try are checking the DL of FF.pnd is correct via its md5sum, which I dont know how to do.


Or you could check the SD card has not gotten set as read only via a chkdisc on a windows PC, or via gparted.pnd (although via the GUI method of this program, this is sometimes not capable of completing the chkdisc function, or formatting, as has been noted by Grench during his tests of 128gb SDXC cards). Dosfstools is also included in gparted and Wizardstan, has previously advised it is possible to minimise gparted, then launch a terminal and enter a linux command for chkdisk function of the relevant SD card manually, which will probably work better. Though I cannot recall the command at present. Additionally you can manually install dosfstools via the angstrom repository via opkg update and opkg install dosfstools and then check the SD card.
 

Sigurd

Member
Joined
Nov 4, 2004
Messages
177
I did indeed try to delete both the appdata folder and the PND it self. I also tried downloading a fresh PND from some new sources. I eventually gave up and just went for a reflashing instead:


Oddly enough it works fine now, so I don't know if Firefox makes some kind of data file somewhere else than on the SD card.


I dunno what to call the thread tho, cause reinstalling the system is not really a solution imo :p
 
Last edited by a moderator:
Top