Release Qemu for Pandora (for rebirth competition)

@Liboicl, Did you install the pcibridge drivers on Pandora?

The drivers are detected wrong. You need to delete the plug and play bios in the hwmanager and install the pci-bridge drivers manually. After that it should find the usb controller etc.

Thought this was on the wiki...

This is a little more clear. I am guessing hardware manager is the same thing as device manager.

So I deleted the plug and play bios, but when I try to install the pci-bridge it says that I do not have any compatible hardware and exits

edit: I see now. You update the driver type to pci bridge in device manager. Then you can install the intel driver. Now on to making the cd rom drive work
Last edited by a moderator:
No clue about rave ejay, as this is a little special, but dancemachine is really useable as you can see in the videos.
Hello back here :)

I tried rave Ejay and same Copyprotection Error as Dance Ejay2,it cannot read its own .mix Format.

Copy Protected Games are a Problem for Qemu,i tried Rollercoaster Tycoon Full Version and it work not.

Maybe you find a Solution for this.

Many other Games work good,when you have Questions post here and The Pandora Qemu Team try to help :)

happy posting :D
I'm starting to wonder should there a separate thread for those of us who really aren't getting anywhere with this emu? ;) I still can't get a colon to appear, coz I'm using the provided drdos and freedos images, and the tip I've been given is to change the language to Italian. Using drdos, the command keyb isn't recognized, and the freedos one defaults to German keyboard(I think), and changing it to Italian doesn't seem to give the right character anyway, so I'm a bit lost! I tried using Qemu manager on windows, hoping I'd be able to load up one of the prepared images from my Pandora, and add my game files to that, but couldn't work that out either! That's my noob failures in a nutshell!! :)

I'll have to check this tomorrow, 6am start in work! Thanks for the info anyway:)

Woot. I always wanted to be able to play old PC games and plus have old operating systems running for the hell of it. I am running into lots of issues with qemu though!

The first issue I had is trying to install Windows 98 SE since the setup bar never went past 5%. No idea why it would freeze there.

Second issue was when I was copying the files from the CD-ROM Image to the Virtual HDD so I could see if that makes a difference... The file copying took at least 2 hours. I timed it while it was doing the "" files and it took about 2 min 30 seconds to copy a single one!

I also tried to install Windows NT 3.51 and I ran into an issue right away... I can't change out the floppy! There are 3 setup disks that need to be used, but since I can't swap disks while qemu is running, I am stuck!

The floppy disk swap issue is the main concern for me! Also the slow file copying and such is also a problem.
You should try to create the images on your pc and run them on pandora then. Saves a lot of time and hassle.
Unless you haven't got a PC....

I'm so tired these days I'm having big problems. Earlier I just wrote a clone of my OS on the netbook to the wrong partition and wiped over 400 gigs of valuable data. Looks like I won't be continuing my efforts at creating the perfect 9x OS on the netbook till I get back to my home PC. I also spilled water which got into the netbooks LCD and made it look like a work of modern art, fortunately it's drying out nicely and you can barely notice it.

Last night I came to the conclusion that the 98 UBCD coupled with 98 lite using micro install and 95 explorer files from 95b OS is the best way to go. If you are trying this, dont install using the UBCD but copy 98lite to C: and run manually. Immediately after install you should delete the cirrus display driver from device manager (important as major problems occur otherwise when updating PCI) but don't reboot. Then update the PCI plug and play to the 440 chipset drivers from the wiki. I also like using the universal vesa driver, and after all the HW from the PCI is installed you can install directX 8.1b. I had it all running pretty smoothly on the netbook. Installing qemm97 is also worthwhile, as is turning off virtual memory. For some reason on my netbook using qemu manager the sound only worked when used SDL sound library instead of directx. I did try installing winME using 98lite and ir froze copying the system files at 44%. Windows 98 FE is prone to massive errors with USB tablet, avoid like the plague. Windows 98 SE has stuttering problems. Use the more up to date 98 UBCD to get the setup files, and very important, use 95b if using 98lite to install - 95c (99% of iso's) works with the installer but caused major DLL/explorer crashes. use winzip to extract cab files from 95b img files. Copy them to a single directory called win95 and save to the 98 boot iso for easy use. You can make it faster for future by just extracting the 3 files 98lite needs from the cabs and saving them in the win95 directory.

Hope that helps.
Somewhat successful. I got the cd drive to show up in windows95, install simcity 2000, and finally run it! Problem is that on reboot the cdrom drive goes crazy and messes up. After I got the intel driver installed It would show the intel controller and 2 ide fifo devices below it. With no cd mounted I had an empty cd drive in my computer and a qemu cd drive in device manager. If I boot windows 95 with a cd image set then the cd drive disappears from my computer and device manager and one of the fifo ide drivers gets an exclamation point. Next I tried setting the driver with the exclamation point to the intel driver and bam cd drive came back and auto started immediately. I thought I found the problem but upon restarting the machine it auto detects new hardware and adds 2 new fifo ide devices to the list, one of them having an exclamation mark, and the cd drive is gone again. Now I can do the same thing to the fifi ide device with the exclamation mark, but on reboot it just adds another 2 and starts over. Im not sure what is going on here, but I did have some success. I would have also got to try starcraft, but for some reason qemu wouldn't launch with the img selected. maybe a bad transfer it worked fine on my pc.

If anyone was wondering simcity 2000 played fine. A little stuttering, but it seemed faster than the dosbox version. Ill give starcraft another try tonight
Hi! for all who its to strong with making Images,have i made the following Games/Demos :)

You must Choose only the Qemu Image and press Start.

Happy Playing

Command&Conquer Demoversion(i didnt found the MSDOS Freeware Version yet)

Star Wars Dark Forces Demoversion

LHX Chopper Simulation Demoversion

PCBert(Freeware Qbert Clone)

Prince of Persia 4D Freeware Remake

Rayman Demoversion(yes it works :D )

Santa in Trouble(nice Jump&Run Freeware)

Skyroads Freeware Xmas Edition

Star Mines 2 Freeware(Asteroids meets Gravity lander)

Stryker Freeware(yes its Freeware now :D )

Teen Agent(Adventure like Flight of the Amazon Queen/Monky Island)

Terminal Velocity Demoversion

TerranFire(the best Freeware Gravity game i have ever played)

Tetris Queen Freeware (very nice Graphics)

Tom&Jerry Freeware

Tomb Raider Demoversion

Triplane (Planebombersimulation works only without Sound)

and nice Graphics but bit stuttering the Demo from Virtual Karts

Enjoy the Games Runnig very easy on your Pandora and dont forget to vote for us :D

and again: Happy Playing ;)
Hi here are new Freshmeat for your Qemu on Pandora,the Images should work on ever Device with Qemu :)

Specially for you here is the Game Stunts inside,because i readed in Wikipedia its REAL FREEWARE.

Enjoy your old Games with the Qemu for Pandora.

DRDos with Demoversion of Descent:

DRDos with Earthworm Jim Demoversion:

DrDos with Demo of FatalRacing/Whipsplash(bit stuttering):

DRDos with the Demo from NeedforSpeed:

DRDos with Sim City Demoversion:

DrDos with Stunts(i readed on Wikipedia it was first Abbandonware but now real Freeware):

DRDos with the Demo from Wacky Wheels:

DRDos with Warcraft2 Demoversion:

DRDos with Warcraft1 Demoversion

My last Post was a few Days here and no one postet here a thx or so,its an Honor for me when you post a Thx or so.

And true: I have Birthday today i am now 31 Years :)

enjoy Gaming with your Pandora and when you want that i package a Freeware or Demo Game for you,send me an PM ;)
many thanks for these images! how easy would it be to say put a full version of game in your image files?

and happy birthday!
Last edited by a moderator:
Well, if you can run the game without the need for a cd, you can just use the shared drive feature of qemu to copy your files into the image.
Happy birthday ingoreis, I'm a year older than you, good to know, listening to my parents this whole project is something childish XD LOL !
So, I tried booting the official ReactOS image for QEMU (ReactOS.vmdk, right?). It starts off fine, but then it gets to a blueish screen (which looks a lot like the Windows XP disk checking screen) that says:

Unable to get file system of D:\

It hangs on that screen for a while, then QEMU ends (I guess that's the machine shutting down or something, I don't know).

This is regardless of what I have set as the CD image.

I also can't for the life of me figure out how to install FreeDOS (every time, after FDISK runs and a reboot happens, it tries to boot from the hard disk and prints "partition signature != 55AA" and hangs), but that's a different topic.
Last edited by a moderator:
Well, if you can run the game without the need for a cd, you can just use the shared drive feature of qemu to copy your files into the image.

Thats the best way because you don't have to reboot/change images to change games. I was having some no cd game issues though and was just trying some things out. The game I was having trouble with also did not fit in the shared folder. I found 2 ways around this. 1 Boot off dos disk with cd support and copy if via command line, 2 mount the whole system image inside a linux box and copy the files that way. Little bit harder due to the format but still doable.