Box86 Error (loading libs) on rasp 4


pgroessw

Newbie
Joined
Jan 2, 2022
Messages
8
Dear experts,
I am quite new to raspberry (therefore please be patient ;-):
I am trying to install WeatherDisplay SW for GUI [Weather Display for Linux GUI 32 version] using Box86 an a rasp 4 - it seems that I am stuck as Box86 is running but an error could not be solved by me - I would appreciate any help from all of the experts here in this forum:
pi@raspberrypi:~/wdisplay $ ./GoWeather.sh
Box86 with Dynarec v0.2.5 727784d9 built on Jan 2 2022 00:07:17
Error: loading needed libs in elf ./WeatherD

Many thanks in advance
Phil
 
  • Like
Reactions: rSl

levi

Still fresh, damnit!
Joined
Oct 6, 2008
Messages
15,853
Location
Somewhere off the coast of the EU
Seems a rather over-terse error message there from box86. What libs are you needing filled? Perhaps you can list the libs needed using 'ldd <libname>' (probably on an x86 box, but I'm not sure to be honest) and that will make things clearer.
 

pgroessw

Newbie
Joined
Jan 2, 2022
Messages
8
Seems a rather over-terse error message there from box86. What libs are you needing filled? Perhaps you can list the libs needed using 'ldd <libname>' (probably on an x86 box, but I'm not sure to be honest) and that will make things clearer.
Thanks a lot for your fast respond!!! And sorry upfront: but how do I list the libs needed - as you mentioned above?
 

pgroessw

Newbie
Joined
Jan 2, 2022
Messages
8
Do you mean:
pi@raspberrypi:~/wdisplay $ ldd GoWeather.sh
not a dynamic executable
pi@raspberrypi:~ $ ldd /bin/ls
linux-vdso.so.1 (0xbef29000)
/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so => /usr/lib/arm-linux-gnueabihf/libarmmem-v7l.so (0xb6f68000)
libselinux.so.1 => /lib/arm-linux-gnueabihf/libselinux.so.1 (0xb6f23000)
libc.so.6 => /lib/arm-linux-gnueabihf/libc.so.6 (0xb6dd5000)
/lib/ld-linux-armhf.so.3 (0xb6f7d000)
libpcre.so.3 => /lib/arm-linux-gnueabihf/libpcre.so.3 (0xb6d5e000)
libdl.so.2 => /lib/arm-linux-gnueabihf/libdl.so.2 (0xb6d4b000)
libpthread.so.0 => /lib/arm-linux-gnueabihf/libpthread.so.0 (0xb6d21000)
 

pgroessw

Newbie
Joined
Jan 2, 2022
Messages
8
pi@raspberrypi:~ $ ldd /bin/ls
linux-vdso.so.1 (0xbef29000)
/usr/lib/arm-linux-gnueabihf/libarmmem-${PLATFORM}.so => /usr/lib/arm-linux-gnueabihf/libarmmem-v7l.so (0xb6f68000)
libselinux.so.1 => /lib/arm-linux-gnueabihf/libselinux.so.1 (0xb6f23000)
libc.so.6 => /lib/arm-linux-gnueabihf/libc.so.6 (0xb6dd5000)
/lib/ld-linux-armhf.so.3 (0xb6f7d000)
libpcre.so.3 => /lib/arm-linux-gnueabihf/libpcre.so.3 (0xb6d5e000)
libdl.so.2 => /lib/arm-linux-gnueabihf/libdl.so.2 (0xb6d4b000)
libpthread.so.0 => /lib/arm-linux-gnueabihf/libpthread.so.0 (0xb6d21000)
pi@raspberrypi:~ $ readelf -d /bin/ls | grep 'NEEDED'
0x00000001 (NEEDED) Shared library: [libselinux.so.1]
0x00000001 (NEEDED) Shared library: [libc.so.6]
0x00000001 (NEEDED) Shared library: [ld-linux-armhf.so.3]

i@raspberrypi:~ $ sudo awk '/\.so/{print $6}' /proc/1/maps | sort -u
/usr/lib/arm-linux-gnueabihf/ld-2.28.so
/usr/lib/arm-linux-gnueabihf/libacl.so.1.1.2253
/usr/lib/arm-linux-gnueabihf/libapparmor.so.1.6.0
/usr/lib/arm-linux-gnueabihf/libargon2.so.1
/usr/lib/arm-linux-gnueabihf/libarmmem-v7l.so
/usr/lib/arm-linux-gnueabihf/libattr.so.1.1.2448
/usr/lib/arm-linux-gnueabihf/libaudit.so.1.0.0
/usr/lib/arm-linux-gnueabihf/libblkid.so.1.1.0
/usr/lib/arm-linux-gnueabihf/libc-2.28.so
/usr/lib/arm-linux-gnueabihf/libcap-ng.so.0.0.0
/usr/lib/arm-linux-gnueabihf/libcap.so.2.25
/usr/lib/arm-linux-gnueabihf/libcrypto.so.1.1
/usr/lib/arm-linux-gnueabihf/libcryptsetup.so.12.4.0
/usr/lib/arm-linux-gnueabihf/libdevmapper.so.1.02.1
/usr/lib/arm-linux-gnueabihf/libdl-2.28.so
/usr/lib/arm-linux-gnueabihf/libgcrypt.so.20.2.4
/usr/lib/arm-linux-gnueabihf/libgpg-error.so.0.26.1
/usr/lib/arm-linux-gnueabihf/libidn.so.11.6.16
/usr/lib/arm-linux-gnueabihf/libip4tc.so.0.1.0
/usr/lib/arm-linux-gnueabihf/libjson-c.so.3.0.1
/usr/lib/arm-linux-gnueabihf/libkmod.so.2.3.4
/usr/lib/arm-linux-gnueabihf/liblz4.so.1.8.3
/usr/lib/arm-linux-gnueabihf/liblzma.so.5.2.4
/usr/lib/arm-linux-gnueabihf/libm-2.28.so
/usr/lib/arm-linux-gnueabihf/libmount.so.1.1.0
/usr/lib/arm-linux-gnueabihf/libpam.so.0.84.2
/usr/lib/arm-linux-gnueabihf/libpcre.so.3.13.3
/usr/lib/arm-linux-gnueabihf/libpthread-2.28.so
/usr/lib/arm-linux-gnueabihf/librt-2.28.so
/usr/lib/arm-linux-gnueabihf/libseccomp.so.2.3.3
/usr/lib/arm-linux-gnueabihf/libselinux.so.1
/usr/lib/arm-linux-gnueabihf/libssl.so.1.1
/usr/lib/arm-linux-gnueabihf/libudev.so.1.6.13
/usr/lib/arm-linux-gnueabihf/libuuid.so.1.3.0
/usr/lib/systemd/libsystemd-shared-241.so
 

pgroessw

Newbie
Joined
Jan 2, 2022
Messages
8
use
Code:
BOX86_LOG=1 ./GoWeather.sh
To have more detail on what is going on, and what lib is missing.
i@raspberrypi:~/wdisplay $ BOX86_LOG=1 ./GoWeather.sh
Debug level is 1
Dynarec for ARM, with extension: HALF FAST_MULT EDSP NEON VFPv4 IDIVA PageSize:4096
Box86 with Dynarec v0.2.5 727784d9 built on Jan 2 2022 00:07:17
Using default BOX86_LD_LIBRARY_PATH: ./:lib/:lib32/:x86/
Using default BOX86_PATH: ./:bin/
Counted 43 Env var
Looking for ./WeatherD
Using native(wrapped) libpthread.so.0
Using emulated ./deploy/libusbdll.so
Using emulated ./deploy/liblunar.so
Using emulated ./deploy/libcom.so
Using native(wrapped) libdl.so.2
Using native(wrapped) libX11.so.6
Using native(wrapped) libgdk_pixbuf-2.0.so.0
Using native(wrapped) libgtk-x11-2.0.so.0
Using native(wrapped) libgdk-x11-2.0.so.0
Using native(wrapped) libgobject-2.0.so.0
Using native(wrapped) libglib-2.0.so.0
Using native(wrapped) libgio-2.0.so.0
Using native(wrapped) libgmodule-2.0.so.0
Using native(wrapped) libpangocairo-1.0.so.0
Using native(wrapped) libpango-1.0.so.0
Using native(wrapped) libgthread-2.0.so.0
Using native(wrapped) libcairo.so.2
Using native(wrapped) libatk-1.0.so.0
Using native(wrapped) libc.so.6
Using native(wrapped) ld-linux.so.2
Using native(wrapped) librt.so.1
Error loading needed lib libusb-0.1.so.4
Error loading one of needed lib
Error initializing needed lib libusbdll.so
Error loading one of needed lib
Error: loading needed libs in elf ./WeatherD
 
  • Like
Reactions: rSl

pgroessw

Newbie
Joined
Jan 2, 2022
Messages
8
Try this
Code:
sudo apt install libusb-0.1
Assuming you are o RPiO4 32bits
pi@raspberrypi:~/wdisplay $ sudo apt install libusb-0.1
Reading package lists... Done
Building dependency tree
Reading state information... Done
Note, selecting 'libusb-0.1-4' for regex 'libusb-0.1'
libusb-0.1-4 is already the newest version (2:0.1.12-32).
libusb-0.1-4 set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
 

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
9,273
Age
50
Location
France, near Lyon
Ah yes. I checked, libusb-1 is wrapped, but not libusb-0.
You''ll have to find a x86 version if this lib and copy it in the program folder (or wait until I wrapped that lib, but I don't know if/when it will happens...)
 

pgroessw

Newbie
Joined
Jan 2, 2022
Messages
8
Ah yes. I checked, libusb-1 is wrapped, but not libusb-0.
You''ll have to find a x86 version if this lib and copy it in the program folder (or wait until I wrapped that lib, but I don't know if/when it will happens...)
Do not rush ;-) - any help appreciated - no need for rush!!
 
  • Like
Reactions: rSl
Top