Civilisation On Castaway


Dec 11, 2004
Whenever I try to save a Civ game on the ST, it doesn't seem to reload - it keeps going straight to the desktop. Please help - I'm dying to be able to play this properly but can't devote the hours required if I can't save it!
try the snes version instead. it was made to be played with a joypad. and savestates work 100% perfect with osnes9x.
I play civ on castaway frequently....

Perhaps you save to the virtual st - disk .... (I never use the save option in civ)

I use the castaway saveslots and it works just fine...
Thanks for your responses guys. Weird - it definitely wasn't reloading earlier but now it is on CaSTaway. I tried the Snes version but, having a Blu+, the savestates seemed to be corrupted when I reloaded them (of course, it's entirely possible I'm doing something wrong).
Should play very nicely on CaSTaway. I may even add a special input mode so the joystick acts as the ST keypad.. this might allow you to control the unit movement in 8-directions instead of just the 4-directions in Cursor mode..

Use a savestate, should work great.

If you're saving to the ST disk image, using the Civ built in saving, then you'd need to also save out the changed disk image in CaSTaway and manage loading it again later. Further, thats broken in the latest CaSTaway/GP due to some floppy disk controller changes I made in the last versions :/ I may roll back those changes, but it seamed moot so far since the disk-read works great and really, everyone should use savestates since they're faster to use, easier to use, and compressed with zip so nice and small :) Why load through 2 or 3 fdloppy changes in Civ when you can snapshot out in 3 seconds :)

Yeah, I was using CaSTaway's savestates and not the ingame ones - it was weird, it just kept kicking me back to the desktop. Then, after posting on here (a couple of hours later), I tried again and it worked fine!

CaSTaway's a great bit of kit - thank you.