Dev Environment Help (ubuntu + Eclipse)


Dingo_aus

Member
Joined
Jan 4, 2006
Messages
133
Age
40
Location
Brisbane, Australia
Website
www.users.on.net
I'm trying to set up a dev environment in Ubuntu 7.10

I've got Eclipse running with CDT all fine.

I've downloaded and installed the toolchain from Open2x. Thus I now have everything sitting in /opt/open2x/gcc-4.1.1-glibc-2.3.6

The problem is I've set up a basic managed c++ project in Eclipse and set up a new configuration called "GP2X"

I've gone through and changed the settings in the new GP2X configuration to point to all binaries/include dirs/libs sitting under the /opt/open2x/gcc-4.1.1-glibc-2.3.6 directory.

I've dealt with a few path errors, and pointed the compiler in the right direction of the libs.

I'm now stuck at compilation process with this error:
QUOTE

as: unrecognized option `-mcpu=arm920t'


The last few lines when I turn on verbose output are:
QUOTE

GNU C++ version 4.1.1 (arm-open2x-linux)
compiled by GNU C version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5).
GGC heuristics: --param ggc-min-expand=100 --param ggc-min-heapsize=131072
Compiler executable checksum: f4127510739b380fe39dc994e3d1e739
as -mcpu=arm920t -mfloat-abi=soft -osrc/gp2x_env_test.o /tmp/ccDSCgFj.s
as: unrecognized option `-mcpu=arm920t'
make: *** [src/gp2x_env_test.o] Error 1
make: Target `all' not remade because of errors.
Build complete for project gp2x_env_test


I'm not sure which file is even feeding the compiler this setting, nor am I sure why the GP2X cross-compiled version of 'as' which I'm using in the settings does nto recognise that option.

Any thoughts on how to fix this?

Ok, I must be more tired than I thought.

The solution, of course, was not to point to the "g++" and "as" version etc but the "arm-open2x-linux-g++" etc version of each tool.

Oh well, glad that is sorted :)
 
Top