Jan 11, 2004
Forgive me if a thread like this has been created before, but I'm a little shaken up at the moment. o_O

Ok, so I decided to try GPDrive, so I put it on my SMC, started it, and put the USB in. It worked just like normal, but when I exited the program (by pressing select), the "removable drive" icon didn't go away in explorer. So, I started GPDrive again, and put the USB in, and the icon went away and came back. When I exited, again, it didn't go away. So I decided to turn the GP32 on in regular vanilla GP32 mode, and that ding that plays when you connect hardware didn't play, so I turned the GP32 off, and I was slapped by a BSOD.

So my computer rebooted, and when windows came back up, it was laggy, and I coulnd't do anything, because nothing would work, so I intentionally BSOD'd again to reboot again, and when it came back up again, same thing, but this time I was able to get into start>run and enable safe mode. Reboot, safe mode, everything's fine. So I get out of safe mode, and windows boots fine, but kinda is acting strange (not all icons appeared in the system tray), so I rebooted a final time, and now everything seems completely 100% normal.

I'm using XP, and I think this may just be a mess up on my part. When gpdrive was active, I tried to 'eject' the drive, but windows wouldn't let me, it came up with an error. Then I tried to eject the drive with the gp32 off, and windows said the drive was in use, and wouldn't let me.

I'm shaken up a little bit, but everything seems to be fine now. Sorry, but I'm afraid to use gpdrive again after this. :S (I know I know, my loss, but I'm comfortable with PC-Link anyway.)

So yeah, did I forget to do something, or does gpdrive just do this?
Doesn't do that to me. To exit, press select, and then unplug you GP32. Don't go down to the "safely remove hardware" thingy. The icon should dissappear.
I intentionally BSOD'ed because clicking shutdown wasn't doing anything. I sat there for like a minute and a half, never took that long. And I BSOD'ed by repeating what I did: USB connect at GPDrive mode, reboot, USB connect at normal GP32 mode, and disconnect.

Do you have to wait at all for the icon to disappear? I hit select and then turned the gp32 off. I didn't 'safely remove hardware' because that was put there for my router.
Also, phodrive is the updated version of gpdrive, you might want to go grab that instead.

Also, my xp takes 10 to 30 seconds sometimes to lose the icon for stopping a device, which you don't need to do with gpdrive/phodrive.
But when the icon goes away, does the "hardware disconnected" sound play, like it's supposed to? That way, you can connect the GP32 in normal mode, and use PC-Link.

So I guess it takes some time for XP to realize the removable drive isn't connected anymore. That makes sense, as I wasn't waiting a long time for the icon to go away. I kinda paniced when the "hardware disconnected" sound didn't play when gpdrive exited, and I turned off the gp32.