Terminal not opening after installing development packages.


meaty

Still Fresh
Joined
Mar 3, 2011
Messages
24
Hello,


Just tried opening the terminal, and this error pops up:


Failed to execute default Terminal Emulator.


Input/Output error.


It was working fine earlier in the session. Any help would be much appreciated.


Just found this out: the pandora button doesn't bring up the kill menu and I can't disable wifi, nor does the root terminal recognise my password.
 
Last edited by a moderator:

meaty

Still Fresh
Joined
Mar 3, 2011
Messages
24
Thanks sebt3, reflashing now.


Update:


Okay, it seems to happen when I run the commands (straight from the thread http://www.gp32x.de/board/index.php?/topic/53964-cross-compiling-is-bollocks-toolchains-are-bollocks-use-your-pandora-to-build-apps/):


sudo bash


opkg update


opkg install gcc_4.3.3 gcc-symlinks gcc-doc make_3.81 make-dev binutils-dev vim_7.2 vim-syntax


opkg install cpp cpp-symlinks


opkg install g++_4.3.3 g++-symlinks


opkg install libstdc++-dev


When I try to ssh into the pandora, I get the error:


-bash: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory


I remember getting a similar error before I reflashed when I tried to run Vim, straight after installing the libstdc++ package.


Is there any fix or do I reflash again? If I reflash, any ideas on what I'm doing wrong when trying to install the development tools?
 
Last edited by a moderator:

mindlord

Notices Two Things
Joined
Mar 10, 2006
Messages
1,790
Location
In a cave.
Website
Visit site
Starting recently ncurses5 is required to keep this stuff from happening.



Code:
sudo opkg update

sudo opkg install ncurses5


Then the rest.
 

meaty

Still Fresh
Joined
Mar 3, 2011
Messages
24
Excellent, thanks mindlord.


I try it out and it comes out with



Code:
:~$ sudo opkg install ncurses5

Collected errors:

 * opkg_install_cmd: Cannot install package ncurses5.





Strangely, it also makes DeadBeef start stuttering while it's trying to install ncurses5. Actually, this happens whenever any opkg installing takes place.



Update: I did

Code:
sudo opkg install ncurses
and it seems to be working. I'll see how this goes and come back with an update.



After



Code:
opkg install gcc_4.3.3 gcc-symlinks gcc-doc make_3.81 make-dev binutils-dev vim_7.2 vim-syntax

it comes out with



Code:
Collected errors:

 * opkg_install_cmd: Cannot install package gcc_4.3.3.

 * opkg_install_cmd: Cannot install package make_3.81.

 * opkg_install_cmd: Cannot install package vim_7.2.


but I can relaunch terminal/vim no problems.
 
Last edited by a moderator:

mindlord

Notices Two Things
Joined
Mar 10, 2006
Messages
1,790
Location
In a cave.
Website
Visit site
Update: I did



Code:
sudo opkg install ncurses
, and it seems to be working. I'll see how this works out and come back with an update.
Sorry meant to say:



Code:
sudo opkg install libncurses5

So try that if the problem persists. Worked for me anyways.
 

meaty

Still Fresh
Joined
Mar 3, 2011
Messages
24
Sweet, I just tried that and it's telling me it's up to date. I'm still getting errors, the most recent being



Code:
Collected errors:

 * opkg_install_cmd: Cannot install package g++_4.3.3.





Woh, lots of errors on the last one.





Code:
sudo opkg install libsdl-1.2-dev libsdl-gfx-dev libsdl-image-1.2-dev libsdl-mixer-dev libsdl-net-1.2-dev libsdl-ttf-2.0-dev


...



Collected errors:

 * check_data_file_clashes: Package libpng-dev wants to install file /usr/bin/libpng12-config

	But that file is already provided by package  * check_data_file_clashes: libpng

 * check_data_file_clashes: Package libpng-dev wants to install file /usr/bin/libpng-config

	But that file is already provided by package  * check_data_file_clashes: libpng

 * opkg_install_cmd: Cannot install package libsdl-gfx-dev.

 * check_data_file_clashes: Package libpng-dev wants to install file /usr/bin/libpng12-config

	But that file is already provided by package  * check_data_file_clashes: libpng

 * check_data_file_clashes: Package libpng-dev wants to install file /usr/bin/libpng-config

	But that file is already provided by package  * check_data_file_clashes: libpng

 * opkg_install_cmd: Cannot install package libsdl-image-1.2-dev.

 * opkg_install_cmd: Cannot install package libsdl-mixer-dev.



Wavebreaker seems to compile with one error





Code:
main.cpp:22:27: error: SDL/SDL_image.h: No such file or directory

Any more dependencies I'm missing? How would I find out what to get myself? A bit of a linux n00b here =)



[edit] Alright, got it working! I did



Code:
sudo opkg install libpng-dev --force-overwrite

sudo opkg install libsdl-image-1.2-dev
 
Last edited by a moderator:
Top