Bricked Gp2X-F200?


RentaHero

Newbie
Joined
May 18, 2015
Messages
1
First of all, hello :) I was an avid reader of this site back in the days of GP32Xtreme, but I never subscribed at the time because I thought I was already active on too many forums :) I had the GP32 but never had the opporunity to get a GP2X and always regretted that... But now that I have one it won't work :(
 
Well let's get to the main topic, if you could help me I'd greatly appreciate :)
 
So I bought a 'broken' GP2X F200, the seller could just tell me that "it doesn't work". So I tried it with two good batteries (2100 mAh each) and it didn't turn on. However the blue LED shined weakly. I could hear the speakers making a 'power on' noise (you know, like the weak 'pop' sound any portable console make when they power on), but the screen stayed pitch black. Then nothing happens.
 
I decided to open it. Then I saw that two capacitors have exploded.
 
One is the C106 on the bottom left of this picture, to the left of the power blue LED.
http://notaz.gp2x.de/img/hw/gp2x_f200_front.jpg
 
The other one is the C106 near the power switch on this picture:
http://notaz.gp2x.de/img/hw/gp2x_f200_back.jpg
 
I replaced them both with brand new 10µF >16V capacitors, with the right polarity, then I tried to boot my console again. The LED shines a bit brighter, I hear the 'pop' sound but again the screen is black and nothing happens.
 
Do you have an idea of what could have happeded, and how to repair my GP2X? Has anybody ever had this problem and solved it? Could it be a fried LTAJT as explained here: http://wiki.gp2x.org/articles/e/x/t/External_power_supply.html ? 
 
Thank you in advance for your help :)
 
Top