Beta Hotfix 4 - Beta 2


tsh

Active Member
Joined
Dec 19, 2008
Messages
775
Location
Cambridge
Website
Visit site
j.pickens said:
I seem to have lost the ability to change screen brightness with the Fn brightness keys.
Related to the Hotfix?
/AOL

The bright_up / bright_down scripts are empty.
 
Last edited by a moderator:

EvilDragon

Administrator
Staff member
Joined
Mar 4, 2003
Messages
29,794
Age
43
Location
Ingolstadt
tsh said:
j.pickens said:
I seem to have lost the ability to change screen brightness with the Fn brightness keys.
Related to the Hotfix?
/AOL

The bright_up / bright_down scripts are empty.

Yep, just saw that, too - no idea what happened here... :eek:
But I have it already fixed, just not committed to the git.
 
Last edited:

GizmoTheGreen

Active Member
Joined
Jul 27, 2009
Messages
835
Age
31
Location
Tokyo, Japan
Lurkio said:
Pleng said:
The green power LED is on to tell you the Pandora is switched on. It doesn't indicate in any way that the unit is plugged in.

oops, that'll teach me to rely on my memory. :(

well if the situation is that your pandora is off, and you plug it in, the green led will show that you plugged the charger in ;)
and that the charger is delivering voltage, if it was dead the gren led wouldnt light up from an off state if you put the charger in :)
 
Last edited by a moderator:

EvilDragon

Administrator
Staff member
Joined
Mar 4, 2003
Messages
29,794
Age
43
Location
Ingolstadt
torpor said:
ED: are you going to include the new wifi drivers in this hotfix, perchance?

Depends on if notaz puts them in the GIT or not ;)
 
Last edited:

urjaman

"I Know. We're going for a ride."
Joined
Jan 6, 2009
Messages
1,111
Age
31
Location
Finland
Website
urjaman.dy.fi
EvilDragon said:
Depends on if notaz puts them in the GIT or not ;)
Hmm he already had a package of them and the git had some activity that seems (according to the thread) to be in the new driver, so I'm 99% sure that he already did.
 
Last edited by a moderator:

notaz

Certified Guru
Joined
Aug 23, 2005
Messages
4,913
Location
Lithuania
Website
notaz.gp2x.de
EvilDragon said:
torpor said:
ED: are you going to include the new wifi drivers in this hotfix, perchance?

Depends on if notaz puts them in the GIT or not ;)
It's already there, but I have a few more patches that I plan to push over the weekend, so if you plan another hotfix now ping me first so we know it all gets in.
 
Last edited by a moderator:

EvilDragon

Administrator
Staff member
Joined
Mar 4, 2003
Messages
29,794
Age
43
Location
Ingolstadt
notaz said:
EvilDragon said:
torpor said:
ED: are you going to include the new wifi drivers in this hotfix, perchance?

Depends on if notaz puts them in the GIT or not ;)
It's already there, but I have a few more patches that I plan to push over the weekend, so if you plan another hotfix now ping me first so we know it all gets in.

No worries - not before the weekend is over :)
I have a wedding to attend to.
 
Last edited:

jdbye

Member
Joined
Dec 27, 2007
Messages
242
Alerino said:
j.pickens said:
I seem to have lost the ability to change screen brightness with the Fn brightness keys.
Related to the Hotfix?

well, still works for me here, no problem
It broke for me as well. Hasn't bothered me too much, the current setting is just bright enough to see it outside (just barely though - Cave Story gets pretty hard to play outside with the dark backgrounds)
 
Last edited by a moderator:

EvilDragon

Administrator
Staff member
Joined
Mar 4, 2003
Messages
29,794
Age
43
Location
Ingolstadt
Jdbye said:
Alerino said:
j.pickens said:
I seem to have lost the ability to change screen brightness with the Fn brightness keys.
Related to the Hotfix?

well, still works for me here, no problem
It broke for me as well. Hasn't bothered me too much, the current setting is just bright enough to see it outside (just barely though - Cave Story gets pretty hard to play outside with the dark backgrounds)

Well, besides the buttons, you can use the brightness control in the LCD Settings. Those still work :)
But I got a new Beta coming up soon :)
 
Last edited:

xopher

Member
Joined
Aug 21, 2008
Messages
263
Location
Where I am
I can not load quake 2 or 3 with the latest image (from Friday). I reflashed and extracted the rootfs to SD. Neither one load the app. These are the only PND that don't seem to function for me; anyone else? I know they're set up properly because I can launch them with an older HF3 SD card extraction; just tried. My brightness doesn't work with the FN key on either NAND boot or SD boot (ED seems to have that rdy for next release though :pandora2ut4: )
 

Blue Ion

Member
Joined
Sep 19, 2008
Messages
177
Location
Madrid, Spain
xopher said:
I can not load quake 2 or 3 with the latest image (from Friday). I reflashed and extracted the rootfs to SD. Neither one load the app. These are the only PND that don't seem to function for me; anyone else? I know they're set up properly because I can launch them with an older HF3 SD card extraction; just tried. My brightness doesn't work with the FN key on either NAND boot or SD boot (ED seems to have that rdy for next release though :pandora2ut4: )
I've tried the latest image for a completely unrelated reason, and it seems there is some disarrangement within the sgx driver. Check "dmesg" if you see symbol mismatches.
Also, my battery reader is kinda wonky. When I flashed the battery was was a little low, but at least 15 or 20%. However, when it boot up, it said there where 0% left of charge, which is impossible since there is at least enough charge to boot the pandora, let linux go "zOMFG THERE IS NO BATTERY LEFT" and shutdown perfectly and normally, twice. I would suspect at 0% the pandora wouldn't even turn on.
I plugged it in and it took a while before the meter started to rise.
Didn't left it plugged in case the pandora won't stop when it hits the maximum.
 
Last edited by a moderator:

EvilDragon

Administrator
Staff member
Joined
Mar 4, 2003
Messages
29,794
Age
43
Location
Ingolstadt
xopher said:
I can not load quake 2 or 3 with the latest image (from Friday). I reflashed and extracted the rootfs to SD. Neither one load the app. These are the only PND that don't seem to function for me; anyone else? I know they're set up properly because I can launch them with an older HF3 SD card extraction; just tried. My brightness doesn't work with the FN key on either NAND boot or SD boot (ED seems to have that rdy for next release though :pandora2ut4: )

Got any output in the /tmp/pndrun*-Logfiles?
 
Last edited:

xopher

Member
Joined
Aug 21, 2008
Messages
263
Location
Where I am
EvilDragon said:
xopher said:
I can not load quake 2 or 3 with the latest image (from Friday). I reflashed and extracted the rootfs to SD. Neither one load the app. These are the only PND that don't seem to function for me; anyone else? I know they're set up properly because I can launch them with an older HF3 SD card extraction; just tried. My brightness doesn't work with the FN key on either NAND boot or SD boot (ED seems to have that rdy for next release though :pandora2ut4: )

Got any output in the /tmp/pndrun*-Logfiles?

QUAKE2
________

rm: cannot remove `/tmp/cpuspeed': No such file or directory
not mounted on loop yet, doing so
LoopMountedon:
/dev/loop1
Filetype is Squashfs
sudo mount -t squashfs /dev/loop1
mounting union!
Filesystem is
[------------------------------]{ App start }[---------------------------------]
cp: `default/..' and `.' are the same file
Quake 2 -- Version 3.21+r0.16
Added packfile ./baseq2/pak0.pak (3307 files)
Added packfile ./baseq2/pak1.pak (279 files)
Added packfile ./baseq2/pak2.pak (2 files)
Added packfile ./baseq2/pak0.pak (3307 files)
Added packfile ./baseq2/pak1.pak (279 files)
Added packfile ./baseq2/pak2.pak (2 files)
using /mnt/utmp/quake2/.quake2/baseq2/ for writing
execing default.cfg
execing config.cfg
Console initialized.

------- sound initialization -------
sound sampling rate: 11025
------------------------------------
------- Loading ref_nanogl.so -------
LoadLibrary("./ref_nanogl.so")
ref_gl version: GL 0.01
NGL: Starting
Using library: libGLES_CM.so
NGL: Library opened! Making the interface
NGL: Size 712
NGL: Starting to dynamically link to 178 functions!
NGL: Linking to eglGetError(0) Pointer 40F795F0 NGL: Linking to eglGetDisplay(1) Pointer 40F795E0 NGL: Linking to eglInitialize(2) Pointer 40F795D0 NGL: Linking to eglTerminate(3) Pointer 40F795C0 NGL: Linking to eglQueryString(4) Pointer 40F795B0 NGL: Linking to eglGetConfigs(5) Pointer 40F79590 NGL: Linking to eglChooseConfig(6) Pointer 40F79580 NGL: Linking to eglGetConfigAttrib(7) Pointer 40F79570 NGL: Linking to eglCreateWindowSurface(8) Pointer 40F79560 NGL: Linking to eglCreatePbufferSurface(9) Pointer 40F79540 NGL: Linking to eglCreatePixmapSurface(10) Pointer 40F79550 NGL: Linking to eglDestroySurface(11) Pointer 40F79530 NGL: Linking to eglQuerySurface(12) Pointer 40F79520 NGL: Linking to eglBindAPI(13)NGL: FATAL ERROR
NGL: Linking to eglQueryAPI(14)NGL: FATAL ERROR
NGL: Linking to eglWaitClient(15)NGL: FATAL ERROR
NGL: Linking to eglReleaseThread(16)NGL: FATAL ERROR
NGL: Linking to eglCreatePbufferFromClientBuffer(17)NGL: FATAL ERROR
NGL: Linking to eglSurfaceAttrib(18) Pointer 40F79450 NGL: Linking to eglBindTexImage(19) Pointer 40F79440 NGL: Linking to eglReleaseTexImage(20) Pointer 40F79430 NGL: Linking to eglSwapInterval(21) Pointer 40F79460 NGL: Linking to eglCreateContext(22) Pointer 40F79510 NGL: Linking to eglDestroyContext(23) Pointer 40F79500 NGL: Linking to eglMakeCurrent(24) Pointer 40F794F0 NGL: Linking to eglGetCurrentContext(25) Pointer 40F794E0 NGL: Linking to eglGetCurrentSurface(26) Pointer 40F794D0 NGL: Linking to eglGetCurrentDisplay(27) Pointer 40F794C0 NGL: Linking to eglQueryContext(28) Pointer 40F794B0 NGL: Linking to eglWaitGL(29) Pointer 40F794A0 NGL: Linking to eglWaitNative(30) Pointer 40F79490 NGL: Linking to eglSwapBuffers(31) Pointer 40F79480 NGL: Linking to eglCopyBuffers(32) Pointer 40F79470 NGL: Linking to eglGetProcAddress(33) Pointer 40F795A0 NGL: Linking to glAlphaFunc(34) Pointer 40F4FB20 NGL: Linking to glClearColor(35) Pointer 40F2C110 NGL: Linking to glClearDepthf(36) Pointer 40F2C010 NGL: Linking to glClipPlanef(37) Pointer 40F5D460 NGL: Linking to glColor4f(38) Pointer 40F68570 NGL: Linking to glDepthRangef(39) Pointer 40F5F600 NGL: Linking to glFogf(40) Pointer 40F38540 NGL: Linking to glFogfv(41) Pointer 40F38590 NGL: Linking to glFrustumf(42) Pointer 40F5EA10 NGL: Linking to glGetClipPlanef(43) Pointer 40F40BE0 NGL: Linking to glGetFloatv(44) Pointer 40F434D0 NGL: Linking to glGetLightfv(45) Pointer 40F40C50 NGL: Linking to glGetMaterialfv(46) Pointer 40F40E00 NGL: Linking to glGetTexEnvfv(47) Pointer 40F43EC0 NGL: Linking to glGetTexParameterfv(48) Pointer 40F44310 NGL: Linking to glLightModelf(49) Pointer 40F5E180 NGL: Linking to glLightModelfv(50) Pointer 40F5E0D0 NGL: Linking to glLightf(51) Pointer 40F5DF20 NGL: Linking to glLightfv(52) Pointer 40F5DE80 NGL: Linking to glLineWidth(53) Pointer 40F4E8D0 NGL: Linking to glLoadMatrixf(54) Pointer 40F5EE80 NGL: Linking to glMaterialf(55) Pointer 40F5DA20 NGL: Linking to glMaterialfv(56) Pointer 40F5D980 NGL: Linking to glMultMatrixf(57) Pointer 40F5E520 NGL: Linking to glMultiTexCoord4f(58) Pointer 40F680C0 NGL: Linking to glNormal3f(59) Pointer 40F674A0 NGL: Linking to glOrthof(60) Pointer 40F5E800 NGL: Linking to glPointParameterf(61) Pointer 40F4E880 NGL: Linking to glPointParameterfv(62) Pointer 40F4E7E0 NGL: Linking to glPointSize(63) Pointer 40F4E5B0 NGL: Linking to glPolygonOffset(64) Pointer 40F4DF20 NGL: Linking to glRotatef(65) Pointer 40F5EC50 NGL: Linking to glScalef(66) Pointer 40F5E330 NGL: Linking to glTexEnvf(67) Pointer 40F52BE0 NGL: Linking to glTexEnvfv(68) Pointer 40F52CF0 NGL: Linking to glTexParameterf(69) Pointer 40F52060 NGL: Linking to glTexParameterfv(70) Pointer 40F51F00 NGL: Linking to glTranslatef(71) Pointer 40F5E250 NGL: Linking to glActiveTexture(72) Pointer 40F519E0 NGL: Linking to glAlphaFuncx(73) Pointer 40F4F220 NGL: Linking to glBindBuffer(74) Pointer 40F2B850 NGL: Linking to glBindTexture(75) Pointer 40F553B0 NGL: Linking to glBlendFunc(76) Pointer 40F4EE40 NGL: Linking to glBufferData(77) Pointer 40F2BD30 NGL: Linking to glBufferSubData(78) Pointer 40F2B4C0 NGL: Linking to glClear(79) Pointer 40F2CD50 NGL: Linking to glClearColorx(80) Pointer 40F2C040 NGL: Linking to glClearDepthx(81) Pointer 40F2BFD0 NGL: Linking to glClearStencil(82) Pointer 40F2BFA0 NGL: Linking to glClientActiveTexture(83) Pointer 40F683F0 NGL: Linking to glClipPlanex(84) Pointer 40F5F440 NGL: Linking to glColor4ub(85) Pointer 40F68430 NGL: Linking to glColor4x(86) Pointer 40F684D0 NGL: Linking to glColorMask(87) Pointer 40F4DDC0 NGL: Linking to glColorPointer(88) Pointer 40F67EC0 NGL: Linking to glCompressedTexImage2D(89) Pointer 40F55470 NGL: Linking to glCompressedTexSubImage2D(90) Pointer 40F56930 NGL: Linking to glCopyTexImage2D(91) Pointer 40F53C90 NGL: Linking to glCopyTexSubImage2D(92) Pointer 40F52E00 NGL: Linking to glCullFace(93) Pointer 40F4EA10 NGL: Linking to glDeleteBuffers(94) Pointer 40F2B760 NGL: Linking to glDeleteTextures(95) Pointer 40F55270 NGL: Linking to glDepthFunc(96) Pointer 40F4E9B0 NGL: Linking to glDepthMask(97) Pointer 40F4DFA0 NGL: Linking to glDepthRangex(98) Pointer 40F5F520 NGL: Linking to glDisable(99) Pointer 40F4F2C0 NGL: Linking to glDisableClientState(100) Pointer 40F68130 NGL: Linking to glDrawArrays(101) Pointer 40F2E920 NGL: Linking to glDrawElements(102) Pointer 40F2F5E0 NGL: Linking to glEnable(103) Pointer 40F4F700 NGL: Linking to glEnableClientState(104) Pointer 40F68290 NGL: Linking to glFinish(105) Pointer 40F49010 NGL: Linking to glFlush(106) Pointer 40F48FB0 NGL: Linking to glFogx(107) Pointer 40F383A0 NGL: Linking to glFogxv(108) Pointer 40F38450 NGL: Linking to glFrontFace(109) Pointer 40F4E440 NGL: Linking to glFrustumx(110) Pointer 40F5E990 NGL: Linking to glGetBooleanv(111) Pointer 40F434A0 NGL: Linking to glGetBufferParameteriv(112) Pointer 40F40FE0 NGL: Linking to glGetClipPlanex(113) Pointer 40F40B40 NGL: Linking to glGenBuffers(114) Pointer 40F2B6A0 NGL: Linking to glGenTextures(115) Pointer 40F55060 NGL: Linking to glGetError(116) Pointer 40F40430 NGL: Linking to glGetFixedv(117) Pointer 40F43500 NGL: Linking to glGetIntegerv(118) Pointer 40F43470 NGL: Linking to glGetLightxv(119) Pointer 40F43A00 NGL: Linking to glGetMaterialxv(120) Pointer 40F43860 NGL: Linking to glGetPointerv(121) Pointer 40F40930 NGL: Linking to glGetString(122) Pointer 40F40460 NGL: Linking to glGetTexEnviv(123) Pointer 40F43530 NGL: Linking to glGetTexEnvxv(124) Pointer 40F43C50 NGL: Linking to glGetTexParameteriv(125) Pointer 40F440F0 NGL: Linking to glGetTexParameterxv(126) Pointer 40F44600 NGL: Linking to glHint(127) Pointer 40F48AD0 NGL: Linking to glIsBuffer(128) Pointer 40F43780 NGL: Linking to glIsEnabled(129) Pointer 40F40910 NGL: Linking to glIsTexture(130) Pointer 40F437F0 NGL: Linking to glLightModelx(131) Pointer 40F5E080 NGL: Linking to glLightModelxv(132) Pointer 40F5DF80 NGL: Linking to glLightx(133) Pointer 40F5DEB0 NGL: Linking to glLightxv(134) Pointer 40F5DDD0 NGL: Linking to glLineWidthx(135) Pointer 40F4F140 NGL: Linking to glLoadIdentity(1ALSA lib pcm.c:7234:(snd_pcm_recover) underrun occured
ALSA lib pcm.c:7234:(snd_pcm_recover) underrun occured
./runquake.sh: line 3: 1979 Segmentation fault ./sdlquake2 +set vid_ref nanogl
[-------------------------------]{ App end }[----------------------------------]
cleanup done


QUAKE3
________

rm: cannot remove `/tmp/cpuspeed': No such file or directory
not mounted on loop yet, doing so
LoopMountedon:
/dev/loop0
Filetype is Squashfs
sudo mount -t squashfs /dev/loop0
mounting union!
Filesystem is
[------------------------------]{ App start }[---------------------------------]
cp: `default/..' and `.' are the same file
ioq3 1.36_SVN1772M linux-arm Feb 15 2010
----- FS_Startup -----
Current search path:
/mnt/utmp/quake3/.ioq3a/baseq3
./baseq3/pak8.pk3 (9 files)
./baseq3/pak7.pk3 (4 files)
./baseq3/pak6.pk3 (64 files)
./baseq3/pak5.pk3 (7 files)
./baseq3/pak4.pk3 (272 files)
./baseq3/pak3.pk3 (4 files)
./baseq3/pak2.pk3 (148 files)
./baseq3/pak1.pk3 (26 files)
./baseq3/pak0.pk3 (3539 files)
./baseq3

----------------------
4073 files in pk3 files
execing default.cfg
execing q3config.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok
----- Client Initialization -----
Couldn't read q3history.
----- Initializing Renderer ----
-------------------------------
QKEY found.
----- Client Initialization Complete -----
----- R_Init -----
Initializing OpenGL subsystem
GLimp_HandleError: 0x3003: (null)
GLimp_HandleError: 0x3001: (null)
GLimp_HandleError: 0x3001: (null)
./runioquake3.sh: line 3: 1891 Segmentation fault ./ioquake3.arm +set x11 1
[-------------------------------]{ App end }[----------------------------------]
cleanup done

Thanks for looking ED

EDIT: something to do with the PNDs themselves? Both failing on line 3 where it looks like it's setting up the display? I do see the screen flash before the SD access appears to finish.
 
Last edited by a moderator:
Top