My Gp2x Can No Longer Mount Nand Or Sd Cards


vinnn

Still Fresh
Joined
Jul 29, 2007
Messages
12
Location
Liverpool, England
Website
Visit site
I was playing Wipeout2097 at 266Mhz when my GP2X locked up.
No biggy as I've had plenty of lockups when overclocking past 250Mhz in PSX4GP2X, this time I just wanted to see if there was much difference as the latest version of PSX4GP2X is so much faster than it used to be...

Anyway I power cycled the GP2X and instantly noticed it had booted back to the default v3.0 skin instead of my favorite skin.
Try as I might my GP2X can no longer see any files on the NAND RAM or on any of my SD cards.

I think the local filesystem may have been corrupted so there might not be a /mnt, /mnt/sd or /mnt/nand directories to mount the flash devices to but I can only guess.
I've tried re-flashing the firmware but the GP2X doesn't see the update during bootup.
I've tried to telnet over USB to try to look at the filesystem but the GP2X just locks up when try to ping it (it replies once before locking up) or establish a telnet session.

It's so frustrating as the GP2X boots and everything but there's no way of getting data on to it.
I'm running out of options apart from shelling out on a new GP2X...

Any suggestions?
 

vinnn

Still Fresh
Joined
Jul 29, 2007
Messages
12
Location
Liverpool, England
Website
Visit site
Your comment reminded me about the USB networking issue when connected to Linux PCs.
Will have to patch the GP2X to sort that out as described HERE.

I've come into work this morning and have successfully got it working on a Windows PC.

My guess was correct, and I was able to telnet onto the GP2X and see that there was no /mnt directory

So...
CODE
mkdir -p /mnt/sd
mkdir /mnt/nand


All OK now,
Cheers
 
Top