PanMAME suddenly won't display any roms


Aug 13, 2009
So it's been about a month or two since I fired up PanMAME. (Hard to believe I know, but I've been burning up the games on PCSX) Anyway, I go to PanMAME today and when it loads the screen says "No game matches the type selection for AdvanceMAME."

I've gone through all the menus trying to go up a group level or change a filter that could be causing the problem but I've had no success. I haven't changed anything with my romset or install of PanMAME. Went ahead and just wiped out PanMAME and started from scratch with a freshly downloaded pnd, a new appdata folder, and a verified 0.106 mame romset transfered to the rom folder. Same thing continues to happen. Has anyone experienced this or no what is up?

It's entirely possible I haven't started up PanMAME since I flashed to the latest hotfix. Is that a known issue?

Yes, normally with a wipe of the complete appdatafolder, it should be set up completely new again.

Linux-Swat is right, please delete the .advance folder (its a hidden folder, if you use thunar, press ctrl+h to show hidden files.
Try booting with the older Kernel (Hold Right shoulder button on power up).

I have found that with Super Zaxxon firmware lots of my (working) Roms don't show up in either Mame4all or PanMame if I boot normally with the latest kernel. They all show up as normal when the old kernel is used.

Not as drastic as your symptoms, but it sounds so similar it'd be worth a quick try.
I will try all of these suggestions and report back today. I did delete the entire panmame appdata folder though, so in regards to the hidden folder shouldn't that have been deleted with it? In any case thanks for the advice guys!
Okay, here are the results of what I did this afternoon.

The following steps I did on Kernel 3.2.

1. Removed PanMAME once more. Deleted the appdata folder once more. Put it back on the card and after the initial setup screen I got the "No game matches the type selection for AdvanceMAME." error again.

2. Went it with thunar and deleted the .advance folder. Got the setup screen again and then the same error again.

3. Grabbed a spare SD card I had laying around, put just PanMame on there and some .106 roms on there for testing. Same error.

Following Asmo's advice I booted to kernel 2.6.27, loaded PanMAME and all my roms were there! Weird.

So either there is a gremlin in my Pandora or I probably just need to reflash the system and see if that does anything. You guys got any other ideas?
Just tried to do a full reflash. To my horror I got an update failed message, but it looks like the update just skipped every step since I'm already running kernel 3.2. That's just my guess... I truly don't know whether to be concerned over that or not. Waiting for the genius to check back on this thread.
I still don't get, whats the problem with PanMAME and the new kernel I have no explaination why the roms are not shown :(
Ahh thanks Asmo and mcobit for helping me troubleshoot this. I'm going to try another reflash then with the working files just to be sure I didn't bork anything with my latest unsuccessful flash. Thanks for the link Asmo.

Mcobit I will happily be your guinea pig on PanMAME if there is something I can help you do to troubleshoot it.