Qemu (DOS)doesn't mount ISO


Feb 9, 2006
hope this is the right section of the forum...i'm trying freedos with qemu,and i wanted to mount an iso of a game(a standard,normal everyday iso that works on any pc)but after i load the file on the qemu interface,and press "launch"..nothing happens.the app didn't even start.if i remove the iso,and press "launch",freedos starts normally.any help?
just a shot in the dark:

qemu can be picky, how big is the file, how is it named, how "complicated" is the path ? Maybe renaming it to something short and putting it in the root of the card could help
Maybe you left a "-boot d" in the "Other options" ?

no,never used anyother options commands ever


renamed the iso to simply "cd.iso",and its big almost 600 mb.placed it on the root of sd card and same issue :(
yeah,about the iso it says :could not open disk image fat:rw/media/primo/cd: operation not permitted

now ,a couple of weeks ago i notced that the files on my sd corrupted quite often and without even doing anything(probably faulty,cheapo sd)so i decided to set the sd to "read only" with that little switch they have on the side.i wonder if this is the problem.

also:i extracted all the contents of such cd on a directoty.mounting such directory gives same results,mounting ONLY a sub-directory of such directory,works fine....o_O maybe its because its full of many files i don't know at this point
strange because i'm absolutely sure i put it on the cd slot,and on the hd i use the freedos qcow
heres a pic proof.i renamed the cd.iso into classic.iso

the .out file says

qemu: -cdrom/media/cstlrck/classic.iso could not open disk image media/primo/qemu/drdosemptywithcdsupport.qcow2: permission denied

2012-11-26 12.53.43.jpg
Last edited by a moderator:
Seems ok.

Try to add:

-boot c

in the other options.

After that, if it doesn't work, maybe clear the config/appdata, and relaunch qemu from scratch ?
Last edited by a moderator:
also:i extracted all the contents of such cd on a directoty.mounting such directory gives same results,mounting ONLY a sub-directory of such directory,works fine....o_O maybe its because its full of many files i don't know at this point
Do you have a smaller cd image to test with ? I had an issue with mounting directories where the size of the content exceeded 500MB, do not know if it is related though.

Edit: sorry, didn't update the thread before posting
Last edited by a moderator:
Only the shared folder should have the limitation of 500 mb as it is mounted as fat filesystem.

I have a similar problem: I want to play a game in Win95 which needs a CD. I converted the CD to an .iso file and try to load it with qemu. When I boot up Win95 it does not show any CD in the drive.

Any ideas?

The pndrun-file does not list any errors ... not sure if it's qemu or Win95 in qemu?

Any ideas?

I also tried a different (more simple .iso), no luck ... the Win95 HD image was created with qemu-manager, on my PC it seemed to work fine ...
@F_Slim please use a msdos Cd-Rom Driver bevore Windows loads ;)

In the Pandora Qemu Wiki find you one working :D
Last edited by a moderator:
Are you sure? The CD-Rom drive is available in the Explorer, it just doesn't have any CD in it (and the Win95 image works with .ISOs using qemu 0.14.1 on my PC?)

EDIT: Actually a CD-Rom driver IS loaded as I just noticed ... that's how I solved the "no CD drive available in Windows- problem :)

EDIT2: Ok, looks like it just doesn't like my .ISOs ... now what? ... stupid copy-protection, I even got 2 copies of the game and now can't use even one of them with the Pandora <_<

Anyway, this makes a lot of games pretty difficult to run, also DOS games that need CDs. DosBox seems to be less picky about ISOs ...

EDIT3: Ok, I managed to trick it into accepting an .ISO with just the data files copied to it to run the game. But it looks like Interstate'76 is too demanding anyways :p
Last edited by a moderator:
Hi everyone,

Sorry to bump this old topic but I have exactly the same problem as Solstar : when I load an cd iso on qemu and press launch, nothing happens. Anyways it looks as if "deleting the config appdata" has worked for him but I have no idea of what that means :wacko:  . Sorry if such a question seems stupid for you but,even if I'm really happy with my pandora, I don't understand everything about it  :D .

Thank you for your future answers.

PS: sorry for my english but it's not my native language 
You want to boot from Iso?
Choose you Iso and in the QEMU additional Commands add boot -d

Then boot it from the CD when the CD is bootable. :)

Edit: And load your Images and Isos please from a Fat32 Partition :)
Last edited by a moderator:
Thx for the answer but adding boot -d hasn't changed anything : when I load my win95 image only and press "Launch !", qemu loads windows 95 but when I try to mount my starcraft iso, nothing happens. 

deleting the config appdata worked perfectly,thanks so muuch!
 However it looks as if Solstar who had exactly the same problem found the solution but I don't know what "deleting the config appdata" actually means.
Ahh i think i know your Problem.
Install a Msdos Cdrom Driver.
Without work that not right.

When you install a msdos cdrom driver who start before Windows start should it show you the CD in Windows.

Search in the Pandora Qemu Wiki,there is a Link for a Dos Cdrom driver.

Install howto:
Copy the File fixide.exe in c:/cdrom and copy the file Mscdex.exe from c:/windows/command there too.

After extracting this fixide.exe install it with the setupD and restart windows.

This should work now :)