[SOLVED] Pandora stuck in a loop trying to boot minimenu


Revenged

Still Fresh
Joined
May 31, 2012
Messages
29
I've set up my Pandora so it boots straight into minimenu, and I've hidden all other categories other than my self-made "favourites". Now, for some reason, it doesn't seem to recognize my SD card anymore and therefore can't find any PNDs. It goes "Setting up menu -> Looking for applications" and then starts this all over again. Rebooting and/or removing battery doesn't help.
 

Revenged

Still Fresh
Joined
May 31, 2012
Messages
29
Okay got it working. It seemed that a screw up file on the SD card was causing it. I copied the files to my new card and then formatted the old one. Now both are working.


Still, it seems that if you set up your minimenu like I did and then remove your SD cards, it won't boot up. Guess you just should not do that.
 
Last edited by a moderator:

subone

Member
Joined
Dec 15, 2013
Messages
42
Age
48
Location
France, near Lyon
i dig up that thread ...

I have the same kind of problem : after configuring minimenu to hide some folders, when i reboot it goes "Setting up menu -> Looking for applications" and then starts this all over again ...

I tried to put a mmenu.conf i found on the Internet on a SD card in a folder called pandora\mmenu but it doesnt help ... same problem it loops.

Do someone have an idea to resolve it ? a minimenu reset or a way to switch to xfce when booting ?
 

FBnil

Waiting to Champion the Pyra to the World...
Joined
Dec 14, 2012
Messages
3,226
Location
Yurp
you would need to get to a prompt to type in "stopmmenu" and "startxfce4"

Shutdown your Pandora, start it up, and hold R1 (right shoulderbutton). You should get into a menu, select "Boot in CLI mode" and press button B to confirm/enter.
Log into the system with your credentials. Now type "stopmmenu" and "startxfce4" (this did not work for me, I had no user access to certain parts of X; a normal reboot worked)

edit: Under root you do get a GUI, but no mouse.
 
Last edited:

subone

Member
Joined
Dec 15, 2013
Messages
42
Age
48
Location
France, near Lyon
you would need to get to a prompt to type in "stopmmenu" and "startxfce4"

Shutdown your Pandora, start it up, and hold R1 (right shoulderbutton). You should get into a menu, select "Boot in CLI mode" and press button B to confirm/enter.
Log into the system with your credentials. Now type "stopmmenu" and "startxfce4" (this did not work for me, I had no user access to certain parts of X; a normal reboot worked)

edit: Under root you do get a GUI, but no mouse.
Boot in CLI mode (Kernel 3.2) is working but

stopmmenu result is :
xfwm4: no process killed
nmwrapper: no process killed


startxfce4 result is :
Starting X server
Fatal server error:
Cannot open log file "/var/log/Xorg.0.log"
...


After booting in CLI mode, maybe i can delete in sudo mode some minimenu conf files in /etc/pandora/ ??

Or should i better reflash SuperZaxxon 1.76 on a fresh SD card ?
 

FBnil

Waiting to Champion the Pyra to the World...
Joined
Dec 14, 2012
Messages
3,226
Location
Yurp
Fastest thing is to reflash.
If you want an X, then "sudo chown $USER /var/log/Xorg.0.log" and I had to
echo "echo 12"> /usr/bin/mcookie

before a sudo startx (but it's not runlevel 5, so some things are not started).

I'm gonna reflash, I also broke mine. too bad for the .bashrc I need to copy
 
  • Like
Reactions: rSl
Top