[SOLVED] SD-Card won't autoboot


mrdoc

Still Fresh
Joined
Mar 9, 2012
Messages
13
Hi Pandora-People,


yesterday my new pandora arrived and I've decided to boot my new OS from SD-Card.


I used the manually way and unzipped the rootfs to a single ext2 partition. In this partition


I created a boot.txt and an autoboot.txt. If I restart the pandora holding R I can choose "Boot from SD Card"


but if I do nothing it wont boot from SD-Card thought I have an autoboot.txt.


Does anybody now what this could be?


Edit1: boot.txt and autoboot.txt have excactly the same content


P.S: Sorry for bad school english :p
 
Last edited by a moderator:

Grench

Forum Addict!
Joined
Oct 3, 2008
Messages
6,623
It could be a few things.


1. Is the OS and autoboot.txt in the first primary partition on the card?


2. Skip autoboot.txt and build your boot.txt file first - get that working. If there is even the slightest typo in that string, then it will fail. Double check that you're calling the proper slot.


Could you post up the contents of your boot.txt file?
 

mrdoc

Still Fresh
Joined
Mar 9, 2012
Messages
13
I have the latest Firmware Zaxxon B4 on my NAND. Couse autoboot didn't work i formatted my SD Card again to ext2 first Partition.


But this time I copied my NAND to this Partition using this manual http://pandorawiki.org/Running_Linux_from_an_SD_card#OR_copy_your_firmware_from_the_NAND_to_the_SD_card


And now autoboot works but I have no screen :(


I can see on the LEDs of SD1 and SD2 that the Pandora is booting but the screen is black.


P.S: My boot.txt/autoboot.txt is excactly the same as described in this link http://pandorawiki.org/Running_Linux_from_an_SD_card#Set_up_your_boot.txt
 

mrdoc

Still Fresh
Joined
Mar 9, 2012
Messages
13
Now I've tried to boot the old Kernel (/boot/uImage) this works.


But the new Kernel (/lib/boot/uImage) makes no screen.
 

mrdoc

Still Fresh
Joined
Mar 9, 2012
Messages
13
Ok I tried again untar the rootfs on my ext2 partiton. Now I'm sure that the first failure (autoboot.txt wasnt excecuted) was because my ext2 Partition wasnt the first one.


But now I have the same Problem again that I cant boot the new kernel. If I boot the old one in /boot/uImage alls works but /lib/boot/uImage makes black screen.
 

mrdoc

Still Fresh
Joined
Mar 9, 2012
Messages
13
I attachted the boot.txt for the new kernel which seems to boot but with black screen.


I do have the latest Zaxxon!
 

Attachments

  • boot.txt
    172 bytes · Views: 99
Last edited by a moderator:

notaz

Certified Guru
Joined
Aug 23, 2005
Messages
4,913
Location
Lithuania
Website
notaz.gp2x.de
P.S: My boot.txt/autoboot.txt is excactly the same as described in this link http://pandorawiki.o...p_your_boot.txt
This is not correct for the new kernel, the article seems to be outdated, I've edited it now. In short, main things for you to fix is to get rid console= argument (to fix boot) and add mmc_core.removable=0 (fix suspend).


You could also use the SD installer to save you from some of this trouble.
 
Last edited by a moderator:

mrdoc

Still Fresh
Joined
Mar 9, 2012
Messages
13
Thank very very much for your help :)


Now all works fine.


I dont want to use the SD Installer couse it creates a FAT Partition for boot and I dont want this.
 

Kosmos

Member
Joined
Apr 10, 2012
Messages
228
P.S: My boot.txt/autoboot.txt is excactly the same as described in this link http://pandorawiki.o...p_your_boot.txt
This is not correct for the new kernel, the article seems to be outdated, I've edited it now. In short, main things for you to fix is to get rid console= argument (to fix boot) and add mmc_core.removable=0 (fix suspend).


You could also use the SD installer to save you from some of this trouble.

I am dealing with why my SD install wont boot the old 2.6 kernel from the SD (It boots 3.2 from SD but 2.6 from NAND).


Your comment got my attention because I have that console= line in my autoboot and wonder why he needed to get rid of it? Trying to understand the boot process to know why I can not boot 2.6 from SD.
 

notaz

Certified Guru
Joined
Aug 23, 2005
Messages
4,913
Location
Lithuania
Website
notaz.gp2x.de
That console= argument redirects boot messages to serial port, and serial port names changed between kernel versions because of driver changes. If you try to send messages to wrong port, the boot process hangs. As almost no one has serial cables anyway, it's best to just get rid of console= kernel argument.
 
Last edited by a moderator:

Kosmos

Member
Joined
Apr 10, 2012
Messages
228
Good to know. BTW my booting the old kernel just got fixed by having boot.txt use the 2.6 kernel and autoboot.txt use the 3.2. then by choosing default boot or boot from SD I get to pick kernel 3.2 or 22.6 in that order. The following page has the dialogue between WizardStan and myself as he suggested the commandline and I tested it out.


The topic starts here


http://boards.openpa...140#entry145854
 
Last edited by a moderator:

notaz

Certified Guru
Joined
Aug 23, 2005
Messages
4,913
Location
Lithuania
Website
notaz.gp2x.de
You could also place another boot.txt in the ext2 partition (if it's on the same card) with different options and it should appear in the boot menu too.
 
Top