Wiz Freezes Right After Start Up


Mega GP Mania
May 17, 2009
North Brunswick, New Jersey
I tried using my Wiz last night and it keeps freezing on me. It powers up ok, I get the black GPH screen, then it goes to the orange Wiz screen and that's where it stays, but it does turn off ok. I used it a couple of days ago with no problem, then this happened. I didn't install anything new or upgrade the firmware as it came with the latest one. It wasn't dropped and wasn't near any sources of heat or cold. Is it bricked?

Any advice would be greatly appreciated!!!

Thanks in advance
I have the same problem with my Wiz from time to time. The solution for me was to keep the firmware on my SD card at all times, and when this happens I reload the firmware (hold R and boot)... this works for me, but it hasn't been a permanent solution. I have to do it from time to time.
I tried what you said and it worked. Is this a common problem? Is it an issue with the latest firmware or some kind of hardware problem? If it is a firmware thing can you downgrade, because it seems from what i've read that 1.0.1 is the more stable?
Anyway, I really appreciate your help trentg, Thanks!
I'm not sure.. I posted about it a while back but nobody replied saying they had the same problem. Obviously though it's not just you... I've always run the 1.1.0 firmware so 1.0.1 might be worth trying.
You could also try to hold the power switch down for about 10-15 seconds when shutting down. That did the trick for me once (it's a full shutdown or something like that).
My Wiz sometimes freezes when the USB is connected. I get the black energy saver screen and can copy the files to the Wiz using Windows, but when i grab the Wiz and touch the screen to disable the screen saver, it does not respond