Autorun.gpu


rei_negishi

Newbie
Joined
Aug 29, 2006
Messages
877
Age
33
Ich habe das Thema schonmal in einem anderen Thread gehabt, aber ich hab das Gefühl, dass es dort untergegangen ist.

Ich habe folgendes Problem:
Hatte mir Payback gekauft und es auf einer SD-Karte zugeschickt bekommen. Leider muss ich jedes mal die Startdatei von Payback auswählen und starten. Abhilfe sollte eine autorun.gpu liefern.

Folgendes ist bisher dabei rausgekommen:
Code:
#!/bin/sh
cd /mnt/sd/Payback
exec ./Payback
Diese startet zwar Payback aber beim Beenden lande ich auf nem Blackscreen.
Code:
#!/bin/sh
cd /mnt/sd/Payback
exec ./Payback.gpe
Diese startet ebenfalls Payback aber beim Beenden wird Payback erneut gestartet.

Ich möchte jetzt aber gerne zurück ins Menu. Wie kann ich das bewerkstelligen? Geht das überhaupt in der autorun.gpu so einzustellen oder liegt es jetzt an der Payback.gpe, die geändert werden müsste?
 

Ziz

Advanced Member
Joined
Jan 15, 2006
Messages
3,584
Hau nach dem
Code:
exec ./Payback
mal ein
Code:
<i>
</i>sync
cd /usr/gp2x
/usr/gp2x/gp2xmenu
ran. Und ich weiß nicht, ob mit oder ohne exec besser ist. Ich habe mir zum Vergleich mal die gpe-file von doukutsu angeschaut und da wird kein Exec benützt. Probieren geht über Studieren. ^_^

Edit: Vielleicht reicht es auch einfach das Exec bei der 2. Variante von dir wegzulassen. :huh: Weil die "Payback.gpe" scheint ja das Menü wieder zu starten, denn sonst wäre das Spiel ja doof. ^_^
 

rei_negishi

Newbie
Joined
Aug 29, 2006
Messages
877
Age
33
Danke für dein Bemühen Cyberpuer. Leider ändert sich bei beiden Varianten nichts. Soll heißen, dass nach dem Beenden wieder Payback gestartet wird.

Hab mir ja auch schon diverse gpe-Dateien angeschaut, aber wirklich weitergebracht hat mich das nicht.
Habe jetzt mal nen Blick auf die Exit-Funktion von GMenu geworfen und die sieht folgendermaßen aus:
Code:
title=Exit
description=verlasse GMenu2X zum original Menu
icon=skin:icons/exit.png
exec=/usr/gp2x/gp2xmenu
params=--disable-autorun
clock=200

Hilft mir das evtl. weiter?
 

EvilDragon

Administrator
Staff member
Joined
Mar 4, 2003
Messages
29,778
Age
43
Location
Ingolstadt
Wie im anderen Thread geposted:
Code:
#!/bin/sh
cd /mnt/sd/Payback
exec ./Payback
cd /usr/gp2x
exec /usr/gp2x/gp2xmenu --disable-autorun
 

rei_negishi

Newbie
Joined
Aug 29, 2006
Messages
877
Age
33
*drop* Auch wenn's jetzt zweimal im Forum steht, bringt es micht nicht weiter. Passiert das gleiche wie vorher. Geh ich auf die Datei "Payback" lande ich nach dem Beenden in nem Blackscreen und geh ichauf die Datei "Payback.gpe" startet Payback erneut.
Liegt es evtl. an meinem Editor mit dem ich die autorun.gpu erstellt habe? Es ist der Windowseigene Editor. Hatte zuvor eine andere autorun.gpu mit ihm geladen und dann nur den Inhalt angepasst und wieder gespeichert.
 

EvilDragon

Administrator
Staff member
Joined
Mar 4, 2003
Messages
29,778
Age
43
Location
Ingolstadt
rei_negishi said:
*drop* Auch wenn's jetzt zweimal im Forum steht, bringt es micht nicht weiter. Passiert das gleiche wie vorher. Geh ich auf die Datei "Payback" lande ich nach dem Beenden in nem Blackscreen und geh ichauf die Datei "Payback.gpe" startet Payback erneut.
Liegt es evtl. an meinem Editor mit dem ich die autorun.gpu erstellt habe? Es ist der Windowseigene Editor. Hatte zuvor eine andere autorun.gpu mit ihm geladen und dann nur den Inhalt angepasst und wieder gespeichert.

Das erklärt es ;)
Der Windows-Editor macht andere Enter-Zeichen als Linux / Unix.
Er führt alles aus bis zu der Stelle, wo Du im Windows-Editor Enter gedrückt hast.

Hol Dir Notepad++ oder den Programmers Notepad, da kannst Du einstellen, dass Du Unix LFs haben willst (wenn Du eine Datei mit Linux LFs lädst, erkennen die das auch automatisch und speichern wieder so).
 

rei_negishi

Newbie
Joined
Aug 29, 2006
Messages
877
Age
33
Ok, ich habe jetzt die autorun.gpu mit Notepad++ erstellt. Unix Format und ANSI Kodierung eingestellt, aber leider bleibt das Ergebnis das gleiche.
Vielmehr kann ich doch da jetzt nicht mehr falsch machen, oder doch?
 

Ziz

Advanced Member
Joined
Jan 15, 2006
Messages
3,584
Postet am besten nochmal deine jetzige ansi-gpe-datei. :wink:
 

Beltar

Member
Joined
Feb 13, 2007
Messages
214
Age
32
Location
Stein (nähe St. Pölten(A))
ICQ
232357654
LOCATION
Stein (nähe St. Pölten(A))
Hi
muss den Tread nochmal Ausgraben.
Ist aus dem jetzt etwas geworden, hab nämlich das gleiche Problem

autorun.gpu:
Code:
<i>
</i>#!/bin/sh
cd /mnt/sd/Gameboy/
exec ./output.gpe
params=--disable-autorun

Es sind alles Windows Enter, aber output.gpe wird geöffnet also glaub ich nicht das es an dem liegt.
Hat wer Lösungsvorschläge?
mfg
Beltar
 

rei_negishi

Newbie
Joined
Aug 29, 2006
Messages
877
Age
33
Also ich habe mich mittlerweile damit zufrieden gegeben, dass nach dem Beenden von Payback durch die Autorun-Datei Payback wieder gestartet wird. :roll:
 

EvilDragon

Administrator
Staff member
Joined
Mar 4, 2003
Messages
29,778
Age
43
Location
Ingolstadt
WIndows-Enter stören eigentlich schon... außer, die haben das mit ner neueren Firmware beseitigt.

Was soll denn das params= ?
Das ist auf ner gmenu2x Config und hat in nem Script nix verloren ;)

Mach das mal hier so:
#!/bin/sh
cd /mnt/sd/Gameboy/
exec ./output.gpe
cd /usr/gp2x
exec /usr/gp2x/gp2xmenu --disable-autorun
 

Beltar

Member
Joined
Feb 13, 2007
Messages
214
Age
32
Location
Stein (nähe St. Pölten(A))
ICQ
232357654
LOCATION
Stein (nähe St. Pölten(A))
EvilDragon said:
WIndows-Enter stören eigentlich schon... außer, die haben das mit ner neueren Firmware beseitigt.

Was soll denn das params= ?
Das ist auf ner gmenu2x Config und hat in nem Script nix verloren ;)

Mach das mal hier so:
#!/bin/sh
cd /mnt/sd/Gameboy/
exec ./output.gpe
cd /usr/gp2x
exec /usr/gp2x/gp2xmenu --disable-autorun

Geht leider noch immer nicht:
Hab jetzt Notepad++ gezogen und auf Linux portiert (Notepad zeigt nur mehr eine zeile an)
FW 3.0; hat sich da vieleicht was geändert?

mfg
Beltar
 

rei_negishi

Newbie
Joined
Aug 29, 2006
Messages
877
Age
33
Also ich habe die letzte von ED gepostete Variante auch ausprobiert (natürlich an Payback angepasst) und bekomme nach dem Beenden nur einen Blackscreen. Das GP2X-Menu (original) wird nicht mehr angezeigt.
 
Top