cant unmount SD CARDS


Lao Rebel

Member
Joined
Feb 6, 2012
Messages
113
after installing BETA5, i can't unmount my sd cards. i can unmount w/out any problems w/ BETA4. so i think the problem is w/BETA 5
 

Lao Rebel

Member
Joined
Feb 6, 2012
Messages
113
Does it give an error when you try to unmount it? If so, what is the error?

it says...


org.freedesktop.hal.storage.unmount-others no <-- (privilege, result)


i have no idea what this means. can you help me? not being able to unmount my sd card is a pain
 

Lao Rebel

Member
Joined
Feb 6, 2012
Messages
113
ha! i posted this ages ago and i came back to repost this same problem! i still have this issue. i hoped reflashing to new Zaxxon would help, but nope. i still get this error message. i cannot unmount SDcards. i don't want to take out my sdcards if i can't unmount. i'm afraid it might corrupt my precious data!!
 

mcobit

Advanced Member
Joined
Jul 28, 2008
Messages
6,910
I think you shouldn't worry too much about corrupting, if you are not using android.


If there is nothing writing to them and no pnds are running, it should be no problem to remove them.


No guarantee though.
 

Grench

Forum Addict!
Joined
Oct 3, 2008
Messages
6,623
I think you shouldn't worry too much about corrupting, if you are not using android.


If there is nothing writing to them and no pnds are running, it should be no problem to remove them.


No guarantee though.

All it takes is blowing up a 128GB four partition card once to change your mind on that.


I've found that my multi-partition cards don't eject properly. It looks like the OS is re-connecting to one of the partitions when I tell it to disconnect another. I.e. on a card with partitions A & B, if I tell it to umount A - fine. If I then tell it to umount B - it re-mounts A then umounts B.


Weird and annoying. It doesn't seem to have quite the difficulty on a single partition card. Your experience may vary.


I do not have an answer other than doing a true shut down, pull the card, re-boot with that slot empty then use single-partition cards in the non-booting slot(s). I'm not sure if that would actually solve it though.
 

Lao Rebel

Member
Joined
Feb 6, 2012
Messages
113
yes i had to unmount by shuting down pandora. but that is inconvenient. i had to shut down a million times a day, that can't be good for pandora. i hate doing that. i hope someone figures this out for me b/c i have no idea. it wasn't like this when i used zaxxon beta 4. there must be a connection.
 

gruso

thunderbox
Joined
Feb 28, 2008
Messages
7,461
Age
44
Location
Sydney, Australia
Website
pandorapress.net
As an aside, why are you running beta 5 and not the full release?


On the unmounting topic, if your cards are FAT formatted you shouldn't have to worry about unmounting. As mcobit said just make sure no read/write operations are happening when you eject. If your cards are Ext* formatted or multi partition, you do need to unmount properly. In any case you should install the latest firmware and see if the problem still exists (and check that thread for any similar reports).
 
Last edited by a moderator:

Lao Rebel

Member
Joined
Feb 6, 2012
Messages
113
i am using the full release, still have same problem. now, are you SURE nothing will get corrupted if i eject w/out unmounting? all my sdcards are FAT32 formatted. i'm just afraid it might mess things up. but if you and mcobit says its ok, then i'm gona do it.

As an aside, why are you running beta 5 and not the full release?


On the unmounting topic, if your cards are FAT formatted you shouldn't have to worry about unmounting. As mcobit said just make sure no read/write operations are happening when you eject. If your cards are Ext* formatted or multi partition, you do need to unmount properly. In any case you should install the latest firmware and see if the problem still exists (and check that thread for any similar reports).
 
Last edited by a moderator:

wdt

Member
Joined
Feb 16, 2009
Messages
114
> i'm just afraid it might mess things up


Type sync in xterm before ejecting?
 
Last edited by a moderator:

gruso

thunderbox
Joined
Feb 28, 2008
Messages
7,461
Age
44
Location
Sydney, Australia
Website
pandorapress.net
i am using the full release, still have same problem. now, are you SURE nothing will get corrupted if i eject w/out unmounting? all my sdcards are FAT32 formatted. i'm just afraid it might mess things up. but if you and mcobit says its ok, then i'm gona do it.
I can't give you a sworn statement or anything. :p But in the all the time I've been using a Pandora, rotating through about a dozen SD cards and inserting/removing them countless times, I've never once had an issue. I only take this relaxed attitude towards FAT formatted cards though.

If I've just completed something like a copy operation, or have just closed an app, I always make sure to give it a second or two (making sure the LED has flashed its last flash) before ejecting.
 
Top