Software Pandora Audio Switch

Ziz

Advanced Member
Joined
Jan 15, 2006
Messages
3,584
Probably. Anyway I improved my GUI this way, that it does the first steps for the user automaticly like adding the needed options in the /etc/bluetooth/audio.conf and replacing ~ by /home/${USER} in /usr/share/alsa/alsa.conf.
Furthermore it removes the asound.conf. For all these three files are backup is created beforehand ;)
So, @canseco: Maybe this version works better out of the box for you. :)
 

canseco

Very Active Member
Joined
Jun 1, 2004
Messages
885
Location
Spain
It works now, and no problems changing back to internal speakers a.k.a hw.

Thanks a lot and keep up the good work, ;)
 

Ziz

Advanced Member
Joined
Jan 15, 2006
Messages
3,584
It works now, and no problems changing back to internal speakers a.k.a hw.

Thanks a lot and keep up the good work, ;)
happy to see it working for you, mate :)
Awesome, that is works for you now!
But I made a mistake, which may break your config files, so this is important for everyone, who updated the plugin between yesterday and today: Please update and follow the following steps to check your configuration for mistakes:

So, what went wrong? While checking the enabled feature in /etc/bluetooth/audio.conf I added some uninitialized memory (==random letters) to the file if all features pas.sh needs, are already activated. So please have a look with sudo rights in the file /etc/bluetooth/audio.conf (e.g. with gksudo mousepad /etc/bluetooth/audio.conf) and check, whether your file looks like this:
Code:
[General]
Enable=\PTi")DSource,Sink,Headset,Socket,Control
It can be anything before the valid features start, as the memory was randomly initialized. For me it weren't even valid letters. So just remove everything, which looks like gibberish, that your file looks like this in the end:
Code:
[General]
Enable=Source,Sink,Headset,Socket,Control
The gibberish should only occur between Enable= and the first feature.

Sorry for the inconveniences!


Regards,
Ziz
 

KickAss

Very Active Member
Joined
Mar 9, 2011
Messages
580
Location
Germany
@Ziz:
youve put an awful amount of work in your own hands with this, buddy
we could call it a "verschlimmbesserung". lol
 

Ziz

Advanced Member
Joined
Jan 15, 2006
Messages
3,584
Well, There is a reason, why there is a German word for it. :D
 

KickAss

Very Active Member
Joined
Mar 9, 2011
Messages
580
Location
Germany
i just revised and updated pas to version 0.5.

i figured hw's software volume control didn't work. i didn't notice before because i never used the software to adjust the volume.
but there may be ppl with broken hardware control (volume wheel) who need functioning software control. well that's fixed now :)
 

fettouhi

Active Member
Joined
Sep 20, 2008
Messages
664
Age
43
Location
Odense S, Denmark
I am trying to get my bluetooth headset to work with pas.sh but I can't find anywhere an option in the bluetooth devices manager of the openpandora to choose a2dp.
[doublepost=1568794157,1568793740][/doublepost]Seems like my OpenPandora has the gnome bluetooth manager installed and you are using in the pictures the bluman-manager. How did you install that?
[doublepost=1568795366][/doublepost]To add a bit more info I am trying to connect my AKG Y50BT headset to the OpenPandora and it seems to pair and connect via the bluetooth applet. I have setup pas.sh described in the above posts and also installed the gui switcher to make it easier to switch betweeen audio outputs. But when I switch to my headset output I either get no sound or sound still goes out from the pandora speakers or the application won't even launch like Giaana's Return etc.
 
Top