Hi :)

@ B-ZaR: switching between /dev/mmcblk0p1 and /media/Pandora did the trick, thanks :D

I thought the device and the mounting point were "pointing" to the same place...

Now I can fully enjoy the potential of MilkyTest UI, and it's great !

On a side note, as Panorama rendering is based on WebKit, would it be possible to "embbed" a simple WebKit web browser inside an UI ? This way we could browse the web without having to use an external application like Midori or FireFox...The same could be applied to other kinds of apps too, like a simple QT based word processor embedded inside an UI...In the case of a tabbed UI, one could switch for example from the web browser to the word processor by pressing left or right trigger...

Opinions ?

Bye and thanks !

Magic Sam
Nice that you got it figured out and thanks for the kind words :)

Yes a light web browser can be added, and it's as simple as adding a WebView component to the UI, because the WebView QML plugin is included in the panorama PND :p. Just a matter of making a UI that works like that :)
Hey there, I am currently starting to use MilkytestUI over PNDStore, because it actually sorts PNDs in a sane manner and I can browse by categories, have icons and screenshots and most important of all (to me) a progress bar for downloads.

Anyway, I just noticed for some reason the UI does not get all available packages (check the screenshots below).
Maybe that's fixed in a recent version of the milkytest library, though. (my Panorama version is

Apart from that, keep up the good work, finally being able to use this I can only say it's as good as I expected (though it could be a little more responsive at times).

Hey, and thanks for the feedback :)

Hm. I'll look into this. If you get milkyhelper and use it to list the packages, do the missing ones show up? Panorama's milky-plugin and Cloudef's milkyhelper both use the same libmilky backend so it would help to know where the problem's at.

When I get wars-gamenode to a deployable state I intend to try and do a more responsive version of milkytest. I have a few ideas :p
Ah no, milkshake is probably right, I checked and it indeed all the missing PNDs seem to be the ones I have on my SD card.
That is very confusing though, I would prefer for them to show up, too, like in PNDStore either with a "you have the latest version" or a "update available icon" as I would expect a list of ALL PNDs (on the other hand it makes sense to exclude them in that list, too, but in my case that was not the most logical option, hmm :S ).
What foxblock says makes sense, maybe sometimes someone (like me) forgets that he has already downloaded an old version and thinks it is not present in the repo anymore.
I'll keep that in mind the next time I add stuff. Meanwhile, if you want to add this yourself:
  1. Change property "installed" on interfaces/MilkyTest/ui.qml line 470 from "false" to ".*" to make all packages visible regardless of their installed status
  2. Edit interfaces/MilkyTest/PackageDelegate.qml line 33 and add new conditional colors to the gradient to differentiate between installed and non-installed packages, for example:
  gradient: Gradient {
              GradientStop { position: 0; color: installed ? "#efe" : (hasUpdate ? "#eef" : "#eee") }
              GradientStop { position: 0.2; color: installed ? "#cdc" : (hasUpdate ? "#ccd" : "#ddd") }
              GradientStop { position: 0.8; color: installed ? "#bcb" : (hasUpdate ? "#bbc" : "#ccc") }
              GradientStop { position: 1; color: installed ? "#9a9" : (hasUpdate ? "#99a" : "#aaa") }
I'm working on a small update, mostly changes backend stuff. While doing it I decided to try out a few performance tweaks and found out what's causing the package list scrolling stutter. The package delegate (graphic representation of a package in the list) is too complex and generating them on the fly makes too much delay. I tried just commenting out the entire package details section of the delegate and scrolling was fluid even at 500MHz. This removes functionality, so it's not an actual fix, but tells me what needs changing. I'm thinking about making a full screen "application details" view that has all the screenshots, description, install/remove/delete buttons and stuff. Any ideas on a layout?
Running Panorama on alpha4 and it doesn't seem to actually 'work'... by that, I mean that it does open/execute and I can navigate the menus just fine... but nothing will actually 'open' that I have attempted to use...
So application launching does not work? Does this happen with all UIs or just some? Could you post the output from trying to launch an application (file named /tmp/pnd_run-panorama.out or something like that)?
Thanks. I'm having some issues with my pandora toolchain at the moment, but I'll try to work it out eventually.

I'd REALLY like to work on panorama more right now, but I REALLY REALLY want to get wars-gamenode to a stable state before I do :)
I'm getting close to reaching a milestone in my other project, after which I plan to get back to working on panorama.

My first priorities will be to create a launcher/package manager UI based on MilkyTest (called something else, ideas?) and make milky-plugin support the awesome new features in Cloudef's libmilky (background downloads, database merges). I have a bunch of ideas on how to make it better and this will probably keep me busy for a while :p . If you have ideas for this new UI (in addition to those already mentioned), now would be a good time to present them. :)

After I have a decent UI up I'll look into some other feature requests to see how feasible they would be. I'm taking suggestions. A ROM indexer/emulator launcher plugin is one I intend to prototype, but I'm not yet sure if I have the time to implement a decent one at this point. If someone who knows his way around Qt wants to give it a try I'll provide assistance the best I can.

Generally speaking, at this point I'll try to do UI and plugin work to make panorama useful in everyday use-cases. The more advanced features (like system settings and application switching) discussed earlier are a lot higher hanging fruits which may be addressed later. First and foremost, I'll try to make using a pandora easier through tight integration.

I'll also prototype using panorama as a "full UI" selectable from pandora's "switch UI" dialog. This is not advised for normal use at this point as it would require installing Qt 4.7 to pandora's NAND (current pandora firmwares have Qt 4.6). We'll have to wait for "Yars" firmware for that.
finally got a chance to get the info you needed for my issue (non-responisve panorama) below is a copy of my .out file:

PND : /media/BOOT/pandora/menu/panorama.pnd
PND_FSTYPE : Squashfs
APPDATADIR : /media/BOOT/pandora/appdata/panorama
PND_CPUSPEED : <unset>
EXENAME : scripts/
ARGUMENTS : <unset>
[ START ]--- Mount the PND ----------
Mounting : mount -t squashfs "/dev/loop3" "/mnt/utmp/panorama"
Mounting the Union FS : mount -t aufs -o exec,noplink,dirs="/media/BOOT/pandora/appdata/panorama=rw+nolwh":"/mnt/pnd/panorama=rr" none "/mnt/utmp/panorama"
[SUCCESS]--- Mount the PND ----------
[ START ]--- Starting the application (scripts/ ) ----------
QIconvCodec::convertFromUnicode: using Latin-1 for conversion, iconv failed for BOM: Bad file descriptor
QIconvCodec::convertFromUnicode: using Latin-1 for conversion, iconv_open failed
QIconvCodec::convertToUnicode: using Latin-1 for conversion, iconv_open failed
QGtkStyle was unable to detect the current GTK+ theme.
Settings are saved in "/mnt/utmp/panorama/settings.cfg"
QInotifyFileSystemWatcherEngine::addPaths: inotify_add_watch failed: No such file or directory
QFileSystemWatcher: failed to add paths: /usr/share/applications, /home/cpunltd/.local/share/applications
Loaded UI Test created by dflemstr.
A test Panorama UI that shows what Panorama is capable of
Loaded UI Test created by dflemstr.
A test Panorama UI that shows what Panorama is capable of
file:///mnt/utmp/panorama/interfaces/Test/ui.qml:105: TypeError: Result of expression 'ui.execute' [undefined] is not a function.
file:///mnt/utmp/panorama/interfaces/Test/ui.qml:105: TypeError: Result of expression 'ui.execute' [undefined] is not a function.
ui.execute? That line has been changed to Applications.execute ages ago. Maybe the PND system has a stuck mount.

sudo umount /mnt/utmp/panorama
sudo umount /mnt/pnd/panorama

After this remove the interfaces directory from panorama's appdata to make sure it's updated from the PND.
don't recall if it ever worked, so maybe I updated and the old appdata is still there, will delete the appdata folder altogether and see what happens... (thought I tried that before, but maybe not... been a while since I tried to work with it)
B-Zar: removing the interfaces folder did the trick... it works now, though I have to double-click on something to get it to open... would be nice to see this as a standalone "desktop" where tabbing between programs works when multitasking and the Pandora button brings up the Panorama interface when pressed. That's the only suggestion I'd have for when you put in the time to make it standalone. But also, keep an app version around as well, for those who wish to stick with using it that way.