pcsx re-armed: can't save configuration for game


ghostwheel

Still Fresh
Joined
Aug 11, 2014
Messages
12
Hi!

I'm trying to play railroad tycoon II on the pcsx rearmed. 

I'm trying to set it up so that I can launch the game directly from an icon. I managed to launch rr tycoon II and load a savestate, but what I can't set up

is to have the controls loaded correctly.

I found that in order to use the nubs as a mouse I have to do the following:

1. menu (space)

2. Controls

3. Port 1 Device Analog

When I save this setup as 'save global config' then this is indeed saved, and works the next time. (but then tomb raider won't work...)

When I try to save with 'save cfg for loaded game', then it isn't loaded the next time.

Here is the commend that loads the game:

/usr/pandora/scripts/pnd_run.sh -p "/media/mmcblk1p1/pandora/apps//pcsx_rearmed_r22.pnd" -e "pcsx.sh" -b "pcsx_rearmed" -a "-cdfile /media/mmcblk1p1/pandora/roms/psx/Railroad_Tycoon_II/EBOOT.PBP -load 1

When I use this command, the game loads correctly, but the port configurations for the game do not load, only the global ones.

I tried to load a config file by using the '-cfg' option:

/usr/pandora/scripts/pnd_run.sh -p "/media/mmcblk1p1/pandora/apps//pcsx_rearmed_r22.pnd" -e "pcsx.sh" -b "pcsx_rearmed" -a "-cdfile /media/mmcblk1p1/pandora/roms/psx/Railroad_Tycoon_II/EBOOT.PBP -cfg /media/mmcblk1p1/pandora/appdata/pcsx_rearmed/.pcsx/cfg/RAILROAD2-SLUS00808.cfg -load 1"

but it still  doesn't use the correct port. Does anyone know why?

 

BTW: When I load pcsx rearmed as usual, and navigate to the cd image, load the game, etc, config is loaded and saved correctly.

Thanks!
 
Last edited by a moderator:

ghostwheel

Still Fresh
Joined
Aug 11, 2014
Messages
12
OK, solved. Looking through the /var/tmp logs revealed that the cfg file is loaded relative to [PND ROOT]/.pcsx/

So with the following command, all works well:

/usr/pandora/scripts/pnd_run.sh -p "/media/mmcblk1p1/pandora/apps//pcsx_rearmed_r22.pnd" -e "pcsx.sh" -b "pcsx_rearmed" -a "-cdfile /media/mmcblk1p1/pandora/roms/psx/Railroad_Tycoon_II/EBOOT.PBP -cfg cfg/RAILROAD2-SLUS00808.cfg -load 1"

I think the cfg should have been loaded relative to where the PND file is mounted...

I also don't understand why without specifying the cfg file, just loading a cd image from a command, the cfg file is not saved or loaded correctly....

Anyway, now all works!! Thanks!
 
Top