Usb Device Not Recognized - Serious Help Needed


Still Fresh
Sep 29, 2006
When I connect my GP2X to a PC (I've tried this on 2 windows XP laptops and a desktop computer), the computer recognizes that a USB device has been connected, but it says 'USB device not recognized'. And it keeps flashing this message on and off every second or two. I've tried USB manager and gone through device manager and things, but as far as i can tell, it says that no drivers are installed.
i've read forums and they all just say that windows XP natively supports it.. and if that still doesn't work, i should install the linux.inf which I have done.. but even when i go onto the USB device in device manager and update the drivers and select linux.inf it says that the driver contains no information about the device.

I can still put things on the SD card via a card reader, but it still stresses me out, considering i've only had it 2 days and it's got a dead pixel already.. - i ordered it from play-asia so i can't afford to send it back to hong kong!

Oh and by the way, it can't be the firmware because it already came with version 2.00 .. and I re-installed version 2.00 anyway just to check.

So.. as far as i can tell, it can't be the computer (as it's XP), can't be the cable (a USB device is noticed), can't be the firmware (re-installed), cant be the USB port (i've tried millions)... please guys, i'm at a loss here.

thanks in advance for your help ^_^


Still Fresh
Aug 19, 2006
It still could be the cable even if it says a USB device is noticed, because that's exactly what happened to me.


Sep 21, 2006
USA Florida
Visit site
It could be your cable. If you are using the cable that came with the unit your out of luck. You need a quality cable (I tried two cables before finding one that worked). If you have one from a camera or other device that works then try that. There are some otential issues with USB 1.0 or 2.0 but try the cable swap first. I ended up using my USB powered hard drive cable till I could find one that worked out of the box.

The USB rules seem to be:

1.) Have a FAT 32 formted SD card in the machine.
2.) No USB Host or Networking to start out (simpler test)
3.) Have a GOOD quality USB cable (not the one that cam with the Unit)
4.) Connect to machine.
5.) Go to setting USB and connect

This should work but there could be other issues, but if the prior steps are not taken then it probably will not work.

Hope this helps.