Configuring and compiling a recent kernel


jgeiss

Still Fresh
Joined
Feb 4, 2012
Messages
23
Location
Germany, Bavaria
Hi there,

I'm currently cross-compiling a Gentoo system for the Pandora using a cross-compiler and QEmu. It works quite well, but now I want to configure and compile a recent kernel.

Until now I used the pandora-kernel from git://openpandora.org/pandora-kernel.git (track -b pandora-3.2 origin/pandora-3.2). This kernel is a little bit old. Now where can I get a more resent kernel?

Which (default) configuration can I use compiling an original kernel. Does it make sense?

Do I need patches for the Pandora? Which and where?

I also saw a kernel at git://git.goldelico.com/gta04-kernel.git which should also be for the Pandora. But what ist the corrent config for this?

Thanks for any help.
 

ingoreis

Advanced Member
Staff member
Joined
Jan 18, 2010
Messages
8,125
Age
39
Location
49.491276,8.423518
Oh a Gentoo for the Pandora?
Sound Interresting :D

I do not know anything about Configuring Kernels.
Maybe our Low Level Guru named Notaz can help here?
He is the Importantest Man behind the Pandora Super Zaxxon OS.
We have to thank him much for his Work on it.
And i met him Personally at the Gamescom.
He is realy a friendly Guy.

Just PM @notaz here in the Forum :D
 

notaz

Certified Guru
Joined
Aug 23, 2005
Messages
4,913
Location
Lithuania
Website
notaz.gp2x.de
It's been a long time since I tried newer kernels. Both mainline and gta04-kernel should boot, but gta04-kernel should have more working drivers. There are no other alternatives (or patches) that I'm aware of. For mainline, use omap2plus_defconfig (make omap2plus_defconfig), for gta04-kernel use letux_defconfig.

We have to thank him much for his Work on it.
Well if it's because of Askarus' thread, there is no need, I just wanted to set up reasonable expectations for his new choice of specialty.
 

jgeiss

Still Fresh
Joined
Feb 4, 2012
Messages
23
Location
Germany, Bavaria
For mainline, use omap2plus_defconfig (make omap2plus_defconfig), for gta04-kernel use letux_defconfig.
Thank you for your help. But unfortunately I am still not able to start the kernel. I tried both omap2plus_defconfig and letux_defconfig with some more drivers activated (especially in graphics for the frame buffer) but I get no hint of the kernel running. After UBoot writes "Staring kernel" nothing seems to happen.

I built the kernel using

make zImage

and

mkimage -A arm -O linux -T kernel -C none -a 0x80008000 -e 0x80008000 -n 'Linux-pherkad' -d arch/arm/boot/zImage arch/arm/boot/uImage

like i did for pandora-kernel 3.2. The pandora kernel runs well, but the gta04 does not. Does anybody have a configuration with at lease start the kernel with output printing to the Pandora display?
 

jgeiss

Still Fresh
Joined
Feb 4, 2012
Messages
23
Location
Germany, Bavaria
The kernel git://git.goldelico.com/gta04-kernel.git is running now, but I failed to get usable key codes for the Pandora and Fn key.

Does anybody know where I can get a patch to make these 2 keys work?
 

Linux-SWAT

Hardcore Member
Joined
Feb 13, 2010
Messages
8,544
That's a nice wiki.
You should definitely do a thread of its own in the other OS forum.
 

levi

Still fresh, damnit!
Joined
Oct 6, 2008
Messages
13,018
Location
Somewhere off the coast of the EU
It's all accessible using the instructions posted on the wiki page as far as I can tell, though the target of that article is installing gentoo under a VM so you'd need to pull out the instruction for getting the kernel and adapt them.

As is, it uses the letux kernel from hns's server, so for Pandora you way as well look into testing letux os and improving it.
 
Top