Dingooa320 Bricked (?) With Unauthorized Screen


Still Fresh
Dec 4, 2010
As the title says, i now have a bricked Dingoo a320 thats apparently bricked, when i tried to flash the custom firmware it cuts to a red screen with a blue box about the size of the text, "Unauthorized" and it wount let me do anything beyond that, when i reset it normally, it loads kinda normal, with an extra blue paw at first, then the usual Dingoo Digital screen, then it cuts instantly to a blue screen with Unauthorized on it this time. Is it permanently bricked, or was it just improperly Flashed and what can i do to correct it if anything can be done. the device was originally purchased from ThinkGeek and its a black Dingoo that originally contained the 1.2v Official(?) firmware installed.
Good news is you can't physically brick a Dingoo, as it has a thing called system-on-chip, that always let you usb boot the dingoo for re-flash procedure.
AFAIK there was a way to reflash the native OS from the "Unauthorized" screen, but I have never tried it myself. Check out dingoonity.org forums for the details, there should be a topic on that somewhere.
Even better news is that instead of trying to reflash native OS, you can flash into Dingux right away. With the same procedure units without the "Unauthorized" screen install it.