Expand Pyra OS on SD card


Active Member
Mar 29, 2014
Hey, all. I appreciate the ability to easily make a SD card loaded with Pyra OS in order to test things without risking borking up the main OS. But the system partition is never expanded to take up the full card, which can limit how much you can do with it. Is there any way to expand the f2fs partition that gets written to the SD card? I remember it being discussed before, but I don’t know if there’s been any changes or workarounds since then.

(For reference, I was trying to experiment with installing Bedrock Linux over Pyra OS. This worked smoothly, but left me with too little space to actually use it for anything.)
Well, I tried ye olde gparted on the Pyra itself (booted from emmc) but it didn't seem to know how to work with that format of partition. I tried it on a more modern linux OS and it says that it resized it successfully, but the Pyra won't boot from it afterwards. (Green logo of death.) This is both before and after compleating initial setup on the card. So unless I'm missing something...
If someone could help me with how they were able to do this, I'd really appreciate it. While I've expanded plenty of partitions before, clearly I'm doing something wrong here because I can't boot off of it after doing so.
How are you installing the image onto your SD Card?
If you use the install-img.sh script (included in the /usr/share/pyra-Dirs) to install the image on the sd card, it automatically uses the full size of the SD Card.

All you need on your pyra is an image, the uboot (which is also in the (/usr/share/dirs) and then you can use the installer to install it on your SD Card, using the full space of the card :)
Aaaahhh. Ok. Never heard of the install-img.sh script before. I was just using etcher on a regular computer. Thank you so much! I'll use that from now on.
Any idea how to resize the root partition on a bullseye system? The f2fs-tools are incompatible with more recent debian versions, so I get "Error: Device size is not sufficient for F2FS volume, more segment needed =12557".
Here are the steps I used for bookworm and then expand into 256GB SDCard:
1. following the steps: https://pyra-handheld.com/wiki/inde...S_root_partition_of_the_pyra-bootable_SD_card
2. boot Pyra into the default OS in eMMC
3. insert your SDCard
4. run fsck.f2fs on /dev/mmcblkX in Pyra
5. run resize.f2fs on /dev/mmcblkX in Pyra
6. now, you can use the bootable SDCard

The key step in here is you cannot resize the SDCard with big size, ex: 256GB, after it has been booted.
But this doesn't work if the default OS on eMMC is already bullseye...
Have you tried it ? No ?

bullseye on eMMC to do resize.f2fs

Boot from the 256GB SDCard
Of course I tried. I get an error when I execute resize.f2fs on bullseye or bookworm.
No, upgraded manually.
But with the SD images I had no luck either.
Anyway, I use a Buster image on SD for resizing.
Do someone actually solved this manual resizing problem ?

We don't need Parted, I simply used the resize option from cfdisk: it worked like a charm !
Note: was with an ext filesystem.
Last edited:
  • Like
Reactions: rSl