F100 Stucks: Help Please


Still Fresh
Feb 22, 2006
Hi everybody,

I will try to explain my situation in details:

I have a F100 with 2.0.0 firmware installed. One day I tried to upgrade it to 2.1.2, and it went fine.

Then I tried to upgrade to 3.0.0. All upgrades are done with full batteries. The screens went several times to Patching... and then seems it is finished, and... the next screen is a... black one.

Now, what is the current state. When I boot the F100, first there is a black screen with logo saying Firmware v2. The next screen is the green one saying firmware 2.0.0 is loading. The third screen is an entirely black one, instead of the default menu screen.

I tried to reflash the GP2X with formatted SD card (the same one that worked with the device before) and firmware 2.0.0, by restarting the GP2X with holding Select + Start, but cannot get the Upgrading screen. Instead of it, the same sequence described above happens.

As far as I learnt out from the discussions here, my GP2X is not fully bricked, so I do not need the JTAG cable for recovery. But how then I can recover my GP2X from the current state. I was going to try the 4.1.x firmware by consecutively upgrading 2.0.0 -> 2.1.2 -> 3.0.0 -> 4.0.0 -> 4.1.x... but seems it is wrong, so once I resolve the problem, I will stick with 2.1.2 version.

Thank you in advance.
There should really be a sticky here about how firmware 2.1.x is the best option for F-100s.
I am puzzled that you get the green screen, yet the update does not load.
You should begin to eliminate posibilities.

Things to try:
*Different SD Card
You said that you re-formatted it and that you have used it to do the other firmware upgrades. Well SD cards can dies, it may be a co-incidence, but stranger things have happened. Your best off trying multiple SD cards to eliminate this as a possible cause

*Re-Download the firmware (in case if got corrupt)
You never know.

*Try a different set of batteries.
I know you said that you used a full set of batteries, but I recently had a scare thinking my gp2x was dead, but it was the batteries. They were freshly charged, even showing a steady 1.4v on a multimeter. Best off using a different pair just-in-case.

It does sound like your GP2X is not dead yet, so don't give up. I strongly recommend trying the different SD card, as a newer or older firmware may have broken compatibility with a previously working card.
Easy. It looks like your NAND has too many errors marked (typical for GPH's dodgy firmware).

Now, don't worry, we'll do fine.

Download the NAND Blanker.
This one runs as a normal GPH firmware, so simply put the files onto the SD Card, insert it into the gp2x and start it using the normal SELECT + START routine.

After that, you can either flash to FW 3.0.0 or back to FW 2.0.0 and then to 2.1.2 (which is what I personally recommend).

Yes, it is the SD card issue ... I changed with another one, and fortunately it works ... I ran the NAND Blanker for any case, and successfully recovered my gp2x to 2.1.2 :p

Thank you all for your suggestions. Now going to put my favorite roms again :p