Just Got My Gp2X... And Almost Immediately Bricked It.


iouri

Still Fresh
Joined
Jul 10, 2011
Messages
1
Hello everyone,

I bought a GP2X F100 last month but had only little time to try it before
last week. I just checked that it worked fine and tried a few games left
there by its previous owner. Last week I finally had some free time and
started to tinker with it.

My first reflex: upgrade the firmware. The device ran smoothly with
firmware 2.(something). But one cannot command one's feelings, and running
2.(something) when 4.1.0 is out was almost unbearable for me :)

So I got firmware 4.0.0 from dl.openhandhelds.org (paying attention to
the notes for the 4.1.0 version that warned me against a possible brick
if I tried a direct upgrade), put it at the root of my sd card, started
the gp2x while pressing start+select, and got to the firmware update
screen. This went on smoothly: very soon I booted this firmware with no
problem, could enjoy the new UI and checked that I could still launch
games.

After such success there was no reason not to go on and I went through the
following steps:
- download firmware 4.1.0
- wipe the sd card
- unpack firmware 4.1.0 to the sd
- start the gp2X while pressing start+select
- wait...
Then nothing happened: the boot splash (big GPH logo on a white
background) just sit there for seconds, then minutes, then tens of
minutes, then more than an hour. I finally got tired and worried, and I
stopped the console.

Then I started it again: I got the same boot splash, with startup sound,
then the red-ish splash of firmware 4.0, but nothing more.

Then I tried to restore the 4.0.0 firmware:
- put it on a blanked sd
- start with start+select pressed.
It failed exactly like the 4.1.0 upgrade: the white boot spash with GPH
logo and startup sound, nothing more.

In the last couple of days, I tried several approaches without success:
downgrade to firmware 2.0.0, upgrade to 4.1.0 again, reinstall 4.0.0
again, start with or without card in the sd slot, ...

The result is always the same: if firmware files are present on the
sd card and I start with start+select pressed, I only have the GPH logo
and startup sound. Otherwise I get the GPH logo and startup sound, then
get stuck on the firware 4.0 red-ish splash. From this I deduce that
u-boot is still functional, and that it still reacts to start+select in
some way. With that in mind, I don't understand why firmware upgrades
still fail!

A few more details:
* I only have a bare gp2x with several packs of reliable batteries
(2700mAh): no PSU, no serial cable, no cradle, ...
* None of the upgrades I tried failed because of power failures:
each time I waited at least half an hour (and more than an hour for
the first few tries) before switching the console off.
The battery level was never even low.

So what do you think? Have my gp2x adventures come to an end, even
before they had a true beginning?

PS (in French): Y a-t-il un marseillais (ou presque) dans la salle ?
 

Orkie

Super Duper Mega GP Mania
Joined
Mar 22, 2006
Messages
2,368
Location
UK
Website
www.gp2x.dev
Any official firmware beyond 2.x is crap anyway. You're best either going back to 2.0->2.1.2 or going straight to Open2x. Try Open2x first, if that doesn't work, you may need to run the NAND blanker which can be found in the firmware section of the archive (since your bootloader is still in tact, no need for the JTAG version).

If you come on #gp2xdev on EFnet you may be able to get help more easily (especially if you manage to catch me on there :p).
 
Top