Release Undertale Launcher


ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,771
Age
47
Location
France, near Lyon
Here is a Launcher for Undertale, the RPG not like the other

This PND is a Launcher, so you'll need to copy the Full game data to be able to play. It will be abble to extract the data from Humble Bundle binary. Just launch the PND 1 time to get instructions.
The launcher use box86 and gl4es. Like with other GameMaker2 game (Locomalito ones for example), this game use GLES2, so may need to use latest SGX driver, and use a Swapfile on CC model.
Also, the game start windowed, no mater what, so press "F4" to go fullscreen.

History log
=========

Build 01
-----------

  • Initial build
  • Hack to map Pandora buttons on Z and X key
 

edgex004

Advanced Member
Joined
Jan 5, 2008
Messages
1,204
Wow how does it run?! I may need to buy this game finally now that you have it running on the Pandora! Thank you, as always.
 

ElPoco

Very Active Member
Joined
Feb 16, 2012
Messages
854
Age
36
Location
Paris, France
I've started playing this morning. So far, it's been working flawlessly at what seems to be full-speed. It's fully reactive, it feels like it's native.
Thanks a lot @ptitSeb !

By the way, I used the Steam version of the game, I had to chmod +x the runner otherwise the launcher just didn't do anything (no message error either).
 

levi

Still fresh, damnit!
Joined
Oct 6, 2008
Messages
13,002
Location
Somewhere off the coast of the EU
I think Ptitseb uses FAT32 cards for development, so such a permissions error might be a simple oversight.

I'm surprised if didn't provide any error message. If I try to run a non-executable file under bash here I get
Code:
bash: ./nonexecutablefile: Permission denied
 

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,771
Age
47
Location
France, near Lyon
Ah yes, I should have forced the runner to be executable.

Box86 check is the file to be run as executable permission, and it should write an error if it's not the case.
 

ElPoco

Very Active Member
Joined
Feb 16, 2012
Messages
854
Age
36
Location
Paris, France
Yes it did so when I tried running it with a box86 I compiled (that's how I realized this was the problem), but the Undertale Launcher doesn't display any error message (even in the console when started with pnd_run)
 

ElPoco

Very Active Member
Joined
Feb 16, 2012
Messages
854
Age
36
Location
Paris, France
I've got a crash (crash to desktop) when facing a boss. I've attached the save. Just walk to the right then, during the boss fight, wait for a few turns. At some point, the game consistently crashes.
 

Attachments

ptitSeb

Serial Porter
Joined
Aug 15, 2012
Messages
8,771
Age
47
Location
France, near Lyon
I tried, and finished the boss "fight" with no issue (but many slowfown) @ElPoco . I noticed that at some point, the whole rectangle where your heart is is moving, apparently creating some FBO. This is quite slow, but maybe your issue is not with box86 but with gl4es. Is it up-to-date too? Also, what version of SGX driver (and mhat hardware, I forgot what model you have) are you using?
 

ElPoco

Very Active Member
Joined
Feb 16, 2012
Messages
854
Age
36
Location
Paris, France
When I tried with a more recent box86 I had a quite recent gl4es build as well.. I'll try changing my SGX driver. I'm on a 1Ghz. I think my driver is 4.03 (I've recently changed, I had briefly tried 4.10 when trying to run Not A Hero but then many other games didn't work so I changed to 4.03, I don't remember which one I used before.)
 

ElPoco

Very Active Member
Joined
Feb 16, 2012
Messages
854
Age
36
Location
Paris, France
I was able to play it from start to (good) end on a 1Ghz Pandora. No crash with the 4.06 drivers. Some slowdowns in some maps and some fights but nothing too problematic.
 
Top