Release VCMI - A rewrite of the Heroes of Might and Magic III Engine

I have already put my installation folder to the specified directory, click OK and relaunch the PNG but all I get is the same 2 messages all over again...
What am I doing wrong. I am sure it is just a beginner's mistake but please could anyone explain what to do step by step to me??
I wasn't online for a few days, so here's my late reply...

try the following:

1. removing the whole "[appdata]/vcmi.yeoldegrove" folder

2. start pnd

3. let the pnd copy the initial files...

4. copy your whole installation directory to "[appdata]/vcmi.yeoldegrove/.vcmi" but do NOT overwrite any files.

5. start pnd again and see if it works
Yeah, I bought it over the weekend too. Is there any way to unpack the installer on Linux (preferably on my Pandora, and preferably not using WINE)?
Last edited by a moderator:
Thanks! I used innoextract on my laptop in the end - tried to get innounpy running on Pandora, but got stuck when it needed the pylzma module.

For reference, I unpacked the GoG exe using innoextract which gave me an app folder and a tmp folder. The tmp folder is just for the GoG instaler, so I nuked that, and from the app folder I copied the contents of the Data, Maps and Mp3 subfolders into the corresponding empty folders in appdata/vcmi.yeoldgrove/.vcmi that it had created when I ran it the first time. Quite easy to do in the end.
That script uses innoextract, which is what I ended up using on my netbook. To be honest I didn't find putting the extracted data in the right format for VCMI to be very taxing, but I guess the script might be useful for some people.
According to the changelog, a number of bugs were stamped on. It talks about AI stability - now whether AI instability would lead to an engine crash or something more innocuous is not known to me. It also talks about bugs in battles - are the crashes you're having happening in battles?
I never really had crashes in battles.

More on the map or when entering castles.

I once experienced a bug where the AI got stuck.

But I hadn't time to test a lot...
I have tried with the complete edition from GOG. When I run it plays constantly a "buzz" over the usual sounds, it's very annoying. The sound worked alright  running the game in a virtualized xp.

Has anyone this problem?