Doom For Gp Gamma Settings

DaveC

Internal Development
Joined
Mar 4, 2004
Messages
9,208
I noticed on my BLU that the areas that are supposed to be black are instead a dark grey. This is like this in both "PC" and "GP32" menu options. This makes the game look kind of more washed out then it should be. Black areas should be an RGB value of 0,0,0, they look to be something like 50,50,50. I think this was done to take into consideration the non-lit and FLU displays. With the BLU this should be changed by having a "BLU" option that is set this way. The non-black areas should be as they are, and black should be totally black so the effect is that the contrast will be better.

Does anyone know if I can hex hack the register values to achieve the desired result or how to do it?

Example:

 

DaveC

Internal Development
Joined
Mar 4, 2004
Messages
9,208
Octavious posted on Oct 21 2004 at 10:55 AM said:
I couldnt find any black in that pic for a few a bit
well, craigx ( or is it graigx  :p  ) is the one to ask

~Octavious

Ok, maybe a bad example. Try the one below. Notice that the buildings in the background are black and the sky dark grey. The original one has the buildings and the sky medium grey. The contrast of the engine needs to be tweaked.

Is there any source code available anywhere?

 
Last edited by a moderator:

DaveC

Internal Development
Joined
Mar 4, 2004
Messages
9,208
Drumaster posted on Oct 22 2004 at 12:24 PM said:
Set GP Doom at the "original PC brightness" if you think it's too clear. ;)
Did that, it is still washed out. The bright areas should be as they are now, the dark/black areas should be darker. I think the PC version had gamma settings by hitting an "Function" key I think, I wonder if it would be possible to get to that option somehow.
 
Last edited by a moderator:

Drumaster

Certified Guru
Joined
Jan 13, 2004
Messages
1,108
Age
39
Location
France (78)
My PC Doom version has not any gamma settings available.
When you put the GP32 enhanced mode in GP Doom it's normal that the black is a little "grey", it's logic...because it's clearer.
But PC enhanced mode is perfect if you don't like grey (black is black for me ;)).
I don't have any washed out color...

If you had a FLU, I would understand but on the BLU I think it's perfect.
 

DaveC

Internal Development
Joined
Mar 4, 2004
Messages
9,208
Drumaster posted on Oct 22 2004 at 07:34 PM said:
My PC Doom version has not any gamma settings available.
When you put the GP32 enhanced mode in GP Doom it's normal that the black is a little "grey", it's logic...because it's clearer.
But PC enhanced mode is perfect if you don't like grey (black is black for me ;)).
I don't have any washed out color...

If you had a FLU, I would understand but on the BLU I think it's perfect.
No, look again. Compare other stuff when it is black like when you turn on the BLU with no card in it and it comes up with a black screen that says something like "no SMC". Then compare it to the black level in GPdoom, it definetly IS grey and not black. This is real obvious if you compare two BLUs side by side (which I did) This causes the contrast to not be as good as it could be.
 
Last edited by a moderator:
Top