Slackware for Pandora 14.0

whoami will tell you who you are.

This is a very bad UNIX habit to be logged as root or belonging to root group.
Unless I'm wrong, the 64GB Samsung microSDXC Class 10 DOES NOT WORK


Edit: Apparently ext4 does not boot...

Tried ext2 and card failed at xserver load (I think it's the card's fault but did not diagnose enough to provide helpful info, sorry)
Last edited by a moderator:
Want to hear something weird? Whenever I boot into SL4P 14-1-4, the memory card in my right slot gets wiped of all data.

I presume this isn't affecting lots of folks, as I probably would have heard about it.

What would you need to me to run to help diagnose this, Linux-SWAT?

I installed SL4P yesterday, on to a 16 GB SD card in the left slot. My right hand card (32 GB in size) was originally formatted in FAT32, though after the first data-wipe yesterday I decided to re-format it into ext4 (apart from anything else I was having trouble executing scripts on a FAT32 card due to (I think) some sort of Linux security measure, hence the "exec" argument in my fstab--not that it worked).

Shortly after installing it, I ran "slackpkg update", and "slackpkg upgrade-all". Here's what I think I did wrong: when it prompted me if I wanted to keep or overrite config files, I chose the overwrite option for all of them. I also then changed the hostname via "netconfig" and "visudo" from "darkstar.op" to "jo.op". After the first data wipe I changed it back because I panicked.

The first time I rebooted SL4P with the memory card inside the right-hand slot, I do remember that it stalled for an unusually long amount of time on a line which looked something like "restoring Pandora settings" (it's at the same time that the screen-brightness gets set to my usual setting). I think it was hung on that line for at least a minute or so. Just about enough time to be busy deleting 20 GBs of data :p . Unfortunately I can't find that line in dmesg, or would it have been logged elsewhere/not-at-all?

After my card got wiped the first time, I chalked it up to magic, so I re-formatted it from FAT32 to ext4, stuck some PNDs back on to it, and then stuck it back in and played some Starcraft. Today, I booted up my Pandora and I once again found my card to be completely emptied. That means all those zergs are gonna be back :(

I've just ran 'find /etc/ -name "*.orig"' and I think I found the list of changed config files:


Does it make sense that any of those config files would cause this? None of them look that related to start-up or SD cards :unsure:

In case you'd need it, here's my fstab:

/dev/mmcblk0p1 / auto defaults,noatime 1 1
proc /proc proc defaults 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0
usbfs /proc/bus/usb usbfs defaults 0 0
tmpfs /var/volatile tmpfs defaults 0 0
tmpfs /dev/shm tmpfs mode=0777 0 0
#tmpfs /media/ tmpfs defaults 0 0
#tmpfs /media/ram tmpfs defaults 0 0
/dev/mmcblk0p2 swap swap defaults 0 0
/dev/mmcblk1p1 /media/HARRY auto defaults,exec,user 0 0

I'll keep testing what I can. I'm hoping to avoid having to re-install all of SL4P.

Thanks for any help in advance :)
Never heard of this, i have no idea why it happens. Probably a bad SD card.

Slackpkg is harmless, even if you use new config files.

Why in the world would you want to put a removable device in the fstab ?

/dev/mmcblk1p1    /media/HARRY    auto    defaults,exec,user    0    0

Just name the card with Gparted...