1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Slackware for Pandora 14.1

Discussion in 'Alternative OS' started by Linux-SWAT, Feb 3, 2014.

  1. joachim

    joachim Member

    Joined:
    May 22, 2013
    Messages:
    299
    I am using the pnd from Pandora repo not from Slackware.

    I am testing some windows software with qemu-i386.

    I found two more working in Slackware.

    - TinyCAD: first run is a bit slow at start but then its fine using only low CPU and RAM resources
    - IrfanView

    trying more and give info

    As I am a Slackware only user I am sorry not trying 14.2 because I did a lot of work into v 14.1 to get all working and installing.
     
  2. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,610
    Don't rush on 14.2, as I said in the development thread it's in beta state and not usable as 14.1.
     
  3. joachim

    joachim Member

    Joined:
    May 22, 2013
    Messages:
    299
    So I tried some more programs in qemu-i386 which are working very well :

    LTSpice
    Eagle
    Picasa
    XnView

    I have one question with Slackware : has anyone got QT5 installed ? After some days of installing I get an error in the process. Some progs need QT5 like Stellarium. With Celestia I get an "system doesnt support OPENGL" error and the pnd of Stellarium is not good when showing text.
     
  4. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,610
    Qt5 is packaged for the 14.2, didn't try for 14.1 . Indeed it's a looooooong compilation. On which Pandora model did you try ?
    Yeah, Celestia and Stellarium are not suitable as is for the Pandora. They need to be tweaked to use glshim, but I have no idea about how to do that.
     
  5. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,610
    I tried to compile qt5 on the 14.1, it failed no matter what, even the one which worked on 14.2 .
     
  6. ptitSeb

    ptitSeb Serial Porter

    Joined:
    Aug 15, 2012
    Messages:
    7,184
    Location:
    France, near Lyon
    Stellarium work on my side, either the old one based on Qt4 (that is on the repo), or newer one based on Qt5 (in my beta thread). The only thing is that the qt5 based may crash on CC model, because of the use of Shaders.

    I don't know about Celestia, never tried to compile it.

    Of course, I'm talking about SuperZaxxon, but Stellarium should run in Slackware I guess, bacause most dependancies are inside the PND.
     
  7. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,610
    Both are compiled and packaged for this 14.1 release.
    I guess it's the qt4 version.
     
  8. joachim

    joachim Member

    Joined:
    May 22, 2013
    Messages:
    299
    Thanks for the Info. Using a GHz model. I checked and Celestia was installed already . It is loading data but then crashes with error " .. windows system doesn't support OpenGL" . I then installed Stellarium but had the same display problem as in the pnd version : Text not readable as told in the Pandora repo.

    Maybe I should try the 14.2 version for some programs.
     
    Last edited: Sep 15, 2016
  9. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,610
    Unfortunately, I don't know how to tweak the source code :/ .
     
  10. joachim

    joachim Member

    Joined:
    May 22, 2013
    Messages:
    299
    I mean I try Slackware 14.2 on a separate SD for some programs.
     
  11. Willkommen

    Willkommen Newbie

    Joined:
    Oct 8, 2016
    Messages:
    23
    i installed, and when i click "Toggle Wifi" or "Toggle USB" say like "mounting pnd failed"
     
  12. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,610
  13. Willkommen

    Willkommen Newbie

    Joined:
    Oct 8, 2016
    Messages:
    23
    Im reinstalling right now, i think is because i dont use a Pandora Sd Card, i use a sd card with .pnd files
    --- Double Post Merged, Oct 9, 2016, Original Post Date: Oct 9, 2016 ---
    More than 4 hours installing slackware. anyone can help?
     
  14. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,610
    Can you give detailed information about your SD card please ?
     
  15. Willkommen

    Willkommen Newbie

    Joined:
    Oct 8, 2016
    Messages:
    23
    Its a Toshiba 8gb, i wait like 5 hours but installed, any way to watch videos? :D (in this slackware)
     
  16. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,610
    This isn't detailed info...
    Well, I guess the card is slow.
    MPlayer is shipped in, just click on any video < 720p and it will play smoothly.
     
  17. Willkommen

    Willkommen Newbie

    Joined:
    Oct 8, 2016
    Messages:
    23
    ok thanks! and any way to watch videos in youtube?? (in slackwave)
     
  18. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,610
    I ship SMTube, but never tested it myself.
     
  19. Willkommen

    Willkommen Newbie

    Joined:
    Oct 8, 2016
    Messages:
    23
    I tested, but dont work. I installed "The Tube" but the PndManager i click run and dont work :(, minitube is a good option?
     
  20. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,610
    I have no idea.
    I was wrong I now remember I tested SMTube a long time ago and it worked.
    Maybe try to update it through sbopkg (check the wiki).
     

Share This Page

Loading...