Slackware for Pandora 14.1

joachim

Member
Joined
May 22, 2013
Messages
404
ak, ok was just wondering, because in SZ normal user has all functions in Gparted.

Another one : after finding that Arduino IDE now has an ARM port I tried to install it.
That worked but is not starting. Says java not found even its there. Maybe it has to do with SF or HF. Is there no way to update Slackware Java version to 8 ?( which is needed).
Because when I copied the installed Java into the arduino dir it is starting but gives error "wrong version" and stops then. So I think I need a newer java and cant find it. :-(
 

edgex004

Advanced Member
Joined
Jan 5, 2008
Messages
1,179
@Linux-SWAT: Do you plan on integrating notaz's hardfloat compatibility layer into SL4P? Perhaps that would help to get Java 8 running.

EDIT: @joachim: another option is to try a hardfloat Debian install.
 

Linux-SWAT

Hardcore Member
Joined
Feb 13, 2010
Messages
8,274
You may also try to use an older IDE.
[doublepost=1460830066,1460823757][/doublepost]I just tested a dirty conversion (using alien) and installation of armhf .deb .
I can run Julia armhf so I guess it works.
I have to sanitize the packages before including them officially.
 

b_o_b

Advanced Member
Joined
Sep 7, 2010
Messages
1,318
I have been playing with Slackware 14.1 - created two users. I wanted one of the users (user1) to have a mini-menu WM and the other (user2) XFCE.
Then I noticed slackware packages are not visible in mini-menu so I wanted to change the WM of the mini-menu user to XFCE.

Whatever I do slackware for user1 keeps on login into mini-menu. As far as I know the config file that manages this is .xinitrc
I even copied the .xinitrc file from user2 home directory to the other. Still after login out and in again it continuously boots mini-menu.
 

Linux-SWAT

Hardcore Member
Joined
Feb 13, 2010
Messages
8,274
You probably have to launch xwmconfig as the user, which is the Slackware tool to select a wm.
 

b_o_b

Advanced Member
Joined
Sep 7, 2010
Messages
1,318
You probably have to launch xwmconfig as the user, which is the Slackware tool to select a wm.
I was logged in as user. Terminal in mini-menu is not working so I needed to install a terminal from PND manager. I then executed xwmconfig from the newly added terminal in mini-menu.
Didn't work and I also tried to reboot (instead of login in and out)

Rebooted and I am now presented with permission error messages if I want to execute xwmconfig again (/mnt/utmp/st/.xwmconfig/tmpscript.sh permission denied)
 

Linux-SWAT

Hardcore Member
Joined
Feb 13, 2010
Messages
8,274
I guess your best bet here is to edit /etc/inittab and change
id:4:initdefault:
into
id:3:initdefault:

So X won't be started and you will be able to use xwmconfig.
Type
startx
after that to ensure the right wm is launched.
Set back the init level after that.

About /mnt/utmp/st/.xwmconfig/tmpscript.sh , I have no idea where it comes from, it's certainly not Slackware-related as/mnt/utmp usage comes with pnds.
 

b_o_b

Advanced Member
Joined
Sep 7, 2010
Messages
1,318
thx - that worked. I am not going to use mini-menu with Slackware then.
 

Linux-SWAT

Hardcore Member
Joined
Feb 13, 2010
Messages
8,274
Glad you could make it.
I tested minimenu years ago and it was ok, I'll try to test it more for the 14.2 release.
 

b_o_b

Advanced Member
Joined
Sep 7, 2010
Messages
1,318
Kodi PND from ptitSeb isn't starting with Slackware. I know PND compatibility isn't 100%, is this one of those cases or is there a method to fix that?
As an alternative I have also checked slackbuild.org and the most recent version for 14.1 is 15.2

ptitSeb's version is more recent 16.1 and I think he also optimized it for Pandora so prefer to get that one working.
 

Linux-SWAT

Hardcore Member
Joined
Feb 13, 2010
Messages
8,274
You can use the slackbuild and tweak it to use the latest sources :
https://slackbuilds.org/repository/14.2/multimedia/kodi/?search=kodi
Flags for the Pandora are "-DPANDORA -O2 -pipe -mcpu=cortex-a8 -mfpu=neon -mfloat-abi=softfp -fPIC".
You can use -O3 instead of -O2 if you want, I think that's what ptitSeb does.

The problem here is that you'll also have to compile some dependencies if I don't have them on my repo.
If you follow the sbopkg way documented below, it can be quite easy :
http://pandorawiki.org/Software_projects/OS/Slackware#Installing_a_program_from_source
 

b_o_b

Advanced Member
Joined
Sep 7, 2010
Messages
1,318
OK so you can use 14.2 slackbuilds for 14.1 too, wasn't aware of that. Nice. I might give it a try whenever I can miss my Pandora for a while for the compiling task.
 

joachim

Member
Joined
May 22, 2013
Messages
404
Qcad was updated to version 3.15.5.3 in the repo and now works with Slackware 14.1. The old version didn't word. Very nice.
 
Top