1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
  2. Dismiss Notice

Slackware for Pandora 14.1

Discussion in 'Alternative OS' started by Linux-SWAT, Feb 3, 2014.

  1. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,613
    SL4P - Slackware for Pandora.

    Version 14.1


    ARMv5te, little endian, software float ("soft-float", "armel"), EABI.

    SL4P Wiki page, installation, updates, advanced usage etc. :
    http://pandorawiki.org/Software_projects/OS/Slackware

    About Slackware :
    http://en.wikipedia.org/wiki/Slackware

    Features :
    -full hardware support
    -12 window managers, including Xfce-4.10, Minimenu and Enlightenment DR17
    -KDE-4.10.5 (512M RAM recommended), installed via internet in two commands
    -pnd support
    -PNDstore and PNDManager support
    -most official Open Pandora setup scripts support
    -rebuilt optimized video player (MPlayer2)
    -integrated YouTube player (SMTube, no Flash plugin needed)
    -rebuilt optimized audio player (XMMS)
    -integrated VOIP with Linphone
    -integrated office suite, with AbiWord and Gnumeric
    -integrated DisplayLink support
    -more than 400 Pandora-optimized pre-compiled packages (hosted @ openpandora.org)
    -slapt-get and gslapt for easy installation of these pre-compiled packages
    -an automatized package building system (sbopkg)
    -three optional standard firewall configs for eth0, usb0 and wlan0
    -other optional firewall configs for routing/firewalling
    -kernel recompilation made easy
    -updates through official Slackware repository
    -the SL4P build system (hosted @ openpandora.org), which can be used to port any Linux/*NIX to Open Pandora
    -official OP 3.X kernel + realtime kernel
    -optimized Notaz's SDL
    -Bsp's c64-tools for the DSP
    -gcc, make, perl, python, python3, ruby, OpenJDK, SFML, etc.

    Not yet included features :
    -no system-wide automounter, only Xfce and some other WM automounts
    -no video playing through Firefox and SeaMonkey, disabled to avoid system crashes

    List of official Slackware ARM 14.1 packages :
    http://ftp.armedslack.org/slackwarearm/slackwarearm-14.1/FILELIST.TXT

    Extra packages compiled for SL4P :
    http://slackware.openpandora.org/pandora/sl4p/sl4p-14.1/packages/PACKAGES.TXT

    Tested .pnd compatibility list :
    http://pandorawiki.org/Software_projects/OS/Slackware/PND-compatibility-list

    ####

    Hi, this is Linux-SWAT.

    I'm the maintainer of SL4P, Slackware For Pandora, and you can find me here :
    http://boards.openpandora.org/

    So this is the 14.1 release.

    The improvement continues.

    Slackware is the most reliable Linux distribution. It includes only stable and tested programs.
    See Slackware as a tool for doing whatever you decide, a workstation, a server, a gaming station, a scientific laboratory etc..

    And the Pandora deserves it.

    If you don't like the default Xfce backdrop, I suggest you to take a look a the ones I included.

    Enjoy.

    ####

    Thanks to OP team :
    http://pandorawiki.org/Team
    (Some are still missing here)

    And other people :
    http://boards.openpandora.org

    Very special HUGE thanks to Notaz.
    Without your help, I probably won't have succeeded.

    Thanks to skeezix for Minimenu help.

    Thanks to milkshake and Tempel for PNDstore help.

    Thanks to McLovin for wi-fi tricks.

    Thanks to sebt3 for solving the /usr/share/applications/op_* mystery.
    Also for compatibility help.

    Mega-Supra-Thanks to Blastrock.
    Join the OP community, man ^^.

    Thanks to Binky for the banners.

    Thanks to B-ZaR for PNDManager, and for helping me to make it run.

    Thanks to ingoreis for spreading the word on the German boards, and creating the USB Image Tool images.

    Thanks to Eric Hameleers for his OpenJDK and OpenJRE packages. Dude, you rock !

    Thanks to pepone for noticing I still used the old SDL.

    Thanks to vandyswa for making VOIP finally possible. That was unexpected !

    Thanks to pder for his port of MPlayer2 and his advices.

    Thanks to slaeshjag for his Keyboard Layout .pnd.

    Thanks to Askarus for his endless feature requests.

    Thanks to F_Slim for his tutorial.

    Thanks to quartercast for having noticed the missing firmwares.

    Thanks to _wb_ for suggesting the truetype fonts path symlink.

    Thanks to PaulForey for reporting the Wi-Fi re-enable bug.

    Thanks to marlim for the SD card.

    Thanks to mindlord for his bug reports.

    Thanks to everyone else not listed here who contributed to find bugs, bring ideas.

    Thanks to the enthusiastic users for the additional motivation.

    Thanks to EvilDragon for providing web space. I'm honoured.

    Thanks to Patrick Volkerding :
    http://slackware.com

    And Stuart Winter :
    http://www.armedslack.org

    Eric Hameleers :
    http://alien.slackbook.org/blog/

    Thanks to all LQ.org answerers :
    http://www.linuxquestions.org

    Thanks to OSS developers.

    And, of course, Richard Stallman and Linus Torvalds.

    ####

    Slackware for Pandora Donations:

    Please consider making a donation.
    This will help the SL4P project and also the whole Pandora community as part of it funds pre-orders.
    To do so, go to PayPal, log in and click on "Send Money". Donate to donation@openpandora.org .
    Important : indicate in the PayPal comment field that you are donating for the Slackware project.

    Then PM me, so I will include you in my Thx list below ;^).

    ----

    The Generous Donators List, may the Computer Gods be with you:

    Thanks to ingoreis.

    Thanks to hmc.

    Thanks to Askarus.

    Thanks to A2000.

    Thanks to cube48.

    Thanks to FZERO.

    Thanks to misterbrisby.

    Thanks to TrashyMG.

    Thanks to Link.

    Thanks to http://www.ithic.com/ the U.S. based Open Pandora shop.

    Thanks to MarioPandio.

    Thanks to FaeMinx.

    ####

    SL4P is a Slackware ARM overlay.
    Slackware ARM is the official ARM Slackware port.
    Slackware ARM was formerly known as ARMedSlack.

    Important notes :
    SL4P is not affiliated in any way with Slackware or Slackware ARM.
    DO NOT contact any of them if you have problems with SL4P. Contact ME.

    SL4P is not affiliated in any way with Open Pandora GmbH or Open Pandora Ltd.
    DO NOT contact any of them if you have problems with SL4P. Contact ME.

    This software is distributed as is.
    You are on your own responsibility when using it.

    ####
     
     
    Last edited by a moderator: Feb 3, 2014
    Tags:
    Shenmue likes this.
  2. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,613
    A bit of extra notes:

    -Zram support is disabled for now (random bug)

    -I'll rework the wiki, all links are 14.0 for now

    -I wished to test more but lost time because of a hd crash

    -Still no Libre Office, as all compilations failed. Maybe because of a bad 64G card

    -Please test and report pnd compatibility on the wiki compat page, it may help for Pyra pnd adjustments
     
    Last edited by a moderator: Feb 3, 2014
  3. ekianjo

    ekianjo Hardcore Member

    Joined:
    May 7, 2012
    Messages:
    8,233
    Location:
    神戸市、日本 (Japan)
    Well done, I will give it a go!
     
  4. ingoreis

    ingoreis Advanced Member

    Joined:
    Mar 7, 2012
    Messages:
    2,795
    Location:
    49.491276,8.423518
    Oh cool,will try it soon.

    Zram is for me not much important because it can slow down some Things.

    Will try to compile some Things and report then.

    Thx for your hard work ;)
     
  5. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,613
    Np ^^.

    Tell me if you create another .img
     
  6. ghostpatch

    ghostpatch Active Member

    Joined:
    May 22, 2011
    Messages:
    524
    Location:
    Germany
    awesome, thanks!

    Perfect to do some portable server stuff, when I get my Pyra
     
  7. joachim

    joachim Member

    Joined:
    May 22, 2013
    Messages:
    299
    Hello,

    so far I tested SL4P 14.1 on a 8GB card with some Office programs and media players.

    Here is what I found out : no sound in music files, error msg in vlc player is like "update alsa plugin"

    no videos playing , vlc msg "no codec for mp4"

    programs not working : ABook(+), Artha,Bard,CoolReader,GVEdit,GraphVizCli,Hackerbooks(+)

    Lyx,TeXWorks,TexLive,ZGRViewer,pdflatex,qpdfview

    (+) are working in 13.37

    working : Abiword, but symbols for load,save etc not shown only red X

    Beaver,Bibliothek,Catlooking Writer,DJView4,SMPlayer (only starting, not playing files - see above)

    Alsa Player (no sound),DocumentViewer,FBReader,FX702pCalc,Gnumeric,LibreOffice from pndstore,MGutenberg,Makagiga,Portabase,OP Bookshelf,Orage Calendar and Globaltime,XPf,qpdfview

    that for now, I will try more

    part 2 is KDE : I installed KDE to try it out, but it is really slow even on 1GHz . There are some nice progs which can be used in XFCE too, can I delete just the desktop and keep the progs ?

    And if I want to install SL4P on my old card with 13.37 - is it possible to just install 14.1 and it keeps all the data without saving it elsewhere (there is a lot, only remember the email etc) ?

    thanks for the help and the good work - I really like slackware

    Joachim
     
  8. joachim

    joachim Member

    Joined:
    May 22, 2013
    Messages:
    299
    hello,

    here are the progs from development

    working : Cmake,Circuit Simulator(-)Emacs,Geany,Glade,Lazarus(-),Qt4 Assistant,Designer,Linguist (all-),SQlitestudio and CLI (both-),SmartSim(-)

    all working in version 13.37 too if not marked (-)

    not working : AVR tools,Arduino,C++ development tools,Geany 1.23,OpenSCAD,PandaBas,ReginaRexx, Ruby,Scratch,UCB Logo

    same in 13.37

    and the good news : SMPlayer 2 is working !! (not in 13.37) but sound still missing :-(

    what can I do ?
     
  9. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,613
    Hi !

    Thanks for you reports.

    At first, you should try the shipped programs vs the pnd you are testing.

    For example, geany is shipped and working, SMPlayer too.

    Also, check /tmp/pndout* for more details about fails.

    If you're brave enough, you can also check/fill the pnd compat wiki page:

    http://pandorawiki.org/Software_projects/OS/Slackware/PND-compatibility-list

    I don't understand your part 2 question.

    To update from previous to 14.1, i'm afraid that you will have to copy the content of your home (don't forget the .* files and folders), and put it back on the new install.
     
  10. Stainy

    Stainy Well-Known Member

    Joined:
    Feb 28, 2005
    Messages:
    1,042
    Location:
    UK
    Great stuff... Is there anyway to upgrade from a previous version? or do I have to image my card again?


    Darren
     
  11. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,613
    Image again ^^.
     
  12. joachim

    joachim Member

    Joined:
    May 22, 2013
    Messages:
    299
    Hello,

    I can still get no sound in audio/video progs

    when I try to play mp3 files in vlc I get the error""update to alsa lib 1.0.23 or higher" but I got 1.0.32

    after updating.

    this is a part of the vlc.out file :

    (process:13383): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.
    Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
    ALSA lib confmisc.c:768:(parse_card) cannot find card '0'
    ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_card_driver returned error: No such file or directory
    ALSA lib confmisc.c:392:(snd_func_concat) error evaluating strings
    ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_concat returned error: No such file or directory
    ALSA lib confmisc.c:1251:(snd_func_refer) error evaluating name
    ALSA lib conf.c:4248:(_snd_config_evaluate) function snd_func_refer returned error: No such file or directory
    ALSA lib conf.c:4727:(snd_config_expand) Evaluate error: No such file or directory
    ALSA lib pcm.c:2239:(snd_pcm_open_noupdate) Unknown PCM default
    [0x47fd7480] oss audio output error: cannot open audio device (/dev/dsp)
    [0x47fd7480] main audio output error: couldn't find a filter for the conversion fi32 -> mpga
    [0x47fd7480] main audio output error: couldn't create audio output pipeline

    what can I do ? This was from beginning of installation.
    thanks for help.
     
  13. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,613
  14. ingoreis

    ingoreis Advanced Member

    Joined:
    Mar 7, 2012
    Messages:
    2,795
    Location:
    49.491276,8.423518
    Aaand a new Image here for easy installing under Zaxxon on the Pandora ^_^

    Slackware 14.1.1 as DiskDump compressed Image.

    http://qemu.openpandora.org/PandoraOperatingSystems/Slackware14.1-1.gz

    Simply load this 2 GB File onto a USB Stick,use a 16GB Card (or bigger)and type(or Copy and paste):


    gunzip -c /media/USBSTICK/Slackware14.1-1.gz | sudo dd of=/dev/mmcblk0p1
    correct /media/USBSTICK/ with your path to the File then ^_^

    And wait and wait until the SD LED on your Pandora is ending with blinking(it belong on the Speed of your SD)

    All Data will be erased on the SD Card and i recommend to use the Restspace on the Card for a Swap Partition ;)

    (That can you simply make with Gparted.PND under Zaxxon)

    From a Stick to SD work faster then from SD to SD :rolleyes:

    A IMZ for Windows Users is uploading too ^_^
     
    Last edited by a moderator: Feb 5, 2014
  15. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,613
    Arrriba !
     
  16. joachim

    joachim Member

    Joined:
    May 22, 2013
    Messages:
    299
    @LinuxSWAT: vlc is working with wav files but not for mp3 , maybe codecs are missing (in 13.37)

    I used vlc for the out file so maybe someone can help me with my problem of having no sound output.

    here some  pnds I tested with 14.1

    education , working in 14.1 but not in 13.37

    Aladin, CircuitSimulator (wont quit),Courserian,Ding,Evopedia,Foxtrot GPS,GCompris,GMapCatcher,GnuXaos,Gperiodic,NightVision3,XPlanet

    not working : Geogebra,Gnuplot,JGnuplot,Mathpiper IDE,Mathomatic,Qucs,R,Reduce,Sage,UCBlogo,Xephem,Yacas

    graphics , working in 13.37 and 14.1

    Document viewer,Gimp 2.8,Geeqie,Xpdf,Xsane

    only in 14.1

    Gimp 2.6,GQviev,ImageJ,Javascreenshot,Pencil,SnapsnapTimer,mtPaint

    not working

    Fotoxx,Grafx2,Mypaint,PandoraImageViewer,QCad,
     
  17. TrashyMG

    TrashyMG Moderator Staff Member

    Joined:
    Jan 18, 2010
    Messages:
    9,667
    codecs for mp3 are never bundled by default for legal reasons..
     
  18. Linux-SWAT

    Linux-SWAT Advanced Member

    Joined:
    Feb 13, 2010
    Messages:
    7,613
    Anyway, they are played fine by Xmms.
     
  19. ingoreis

    ingoreis Advanced Member

    Joined:
    Mar 7, 2012
    Messages:
    2,795
    Location:
    49.491276,8.423518
    I will test PanPlayer2 soon under Slackware maybe i can modify a Special Slackware PND Version ;)
     
  20. Askarus

    Askarus Advanced Member

    Joined:
    Sep 28, 2011
    Messages:
    3,892
    Location:
    Germany
    Nice to see you back and more active again :) .

    I'm hoping for some random nonsense in other threads ;) .

    BTW: Will you also support the Pyra with your great SOLEIL build?

    It would be pretty awesome to put this on the NAND.
     

Share This Page

Loading...