Unable To Install Gcc And Friends Since Hf5


Stuckie

Member
Joined
Apr 7, 2004
Messages
492
Age
35
Location
Tired, and sleeping in the basement...
Website
www.stuckieworld.net
I still have a (mostly) clean HF5(maybe RC2, can't remember right now) rootfs working with gcc et al on it.. if I find some time (hah.. all my time has disappeared recently - reason why I haven't really managed to get another Debian released pushed out :( ) I'll get that uploaded to my server if it'll help at all as an interim measure at least.

It's what I've been using to do my engine coding stuff recently, so it certainly works.

Should probably be able to get it up in the morning.. far too tired just now to hunt it down :(
 

iampanis

Still Fresh
Joined
May 29, 2010
Messages
61
The issue seems to be the packages messing up the ncurses libs.

So I booted from my (mostly stock) NAND, then inserted my bootable SD with dev stuff, and did:

cd /usr/lib
sudo cp libncurses* /media/<SD name>/usr/lib

That should work.

EDIT: mistyped a filename.
 

DoubleDash

Member
Joined
Jan 30, 2011
Messages
122
mindlord said:
I've reproduced this problem three times on two different SD cards now. I'm fairly certain this is a show stopper for me, can someone else confirm.

If you use the HF5 image and extract it to an SD card. It goes off without a hitch.
I even am able to safely install Firefox and libsqlite3-0 without mucking anything up.
However, if you install GCC and friends you're done-for.

I was (more or less) following Torpor's advice from the "Bollocks" thread.
Code:
opkg install gcc gcc-symlinks gcc-doc make make-dev binutils-dev cpp cpp-symlinks g++ g++-symlinks libstdc++-dev
Installing these packages will cause executables to no longer launch, sometimes reporting an IO error in X, most of the time crashing silently. If you reboot, your game is over - XFCE will fail to load at all.

I dev exclusively directly on my Pandora, so unless someone has some advice. I will not be upgrading beyond HF4.

Hi mindlord

You are not alone!

I had a perfectly working "bollocks" setup on my sd card. Along comes HF5 + reinstall of Torpor's toolchain, and bang, I could no longer boot from the sd card! However, I have fixed it and now have a working development environment on SD with HF5. Before I get to this I should say that when I was doing my failed opkg installs the process took forever (6 hours) and it seemed to be pulling all kinds of stuff down! I think it went a bit crazy and strongly suspect that this is what trashed my original sd setup.

What I did!

In a nutshell I downloaded the packages, went offline, and manually installed them using a couple of scripts. I liked this route also as it meant that the setup of the development environment when prepared can be done entirely offline :)

Your problem may not be the same but I will include the scripts here just in case this provides a working solution for you.

download.sh
Code:
#!/bin/bash
#opkg update
opkg download gcc gcc-symlinks gcc-doc make make-dev binutils-dev
opkg download cpp cpp-symlinks
opkg download g++ g++-symlinks
opkg download libstdc++-dev
opkg download libgles-omap3-dev libgles-omap3-demos
opkg download libsdl-1.2-dev libsdl-gfx-dev libsdl-image-1.2-dev libsdl-mixer-1.2-dev libsdl-net-1.2-dev libsdl-ttf-2.0-dev

install.sh
Code:
#!/bin/bash

#NOTES
#Before running this script to install the development libraries make sure
#that you have run the download script to pull the packages from the web.
#In this example change to a folder where you want to put your scripts
#e.g. 'cd /media/SDHC-OS/xt-chain'
#Execute the script to download the packages from the Anstrom repository:
#'sh download.sh'
#When this is done you can .....unfinished comments !!!



sudo opkg install /media/SDHC-OS/x-tchain/libsdl-image-1.2-dev_1.2.10-r5.2.6_armv7a.ipk

sudo opkg install /media/SDHC-OS/x-tchain/gcc_4.3.3-r23.1.6_armv7a.ipk
sudo opkg install /media/SDHC-OS/x-tchain/gcc-symlinks_4.3.3-r23.1.6_armv7a.ipk
sudo opkg install /media/SDHC-OS/x-tchain/gcc-doc_4.3.3-r23.1.6_armv7a.ipk
sudo opkg install /media/SDHC-OS/x-tchain/make_3.82-r0.6_armv7a.ipk
sudo opkg install /media/SDHC-OS/x-tchain/make-dev_3.82-r0.6_armv7a.ipk
sudo opkg install /media/SDHC-OS/x-tchain/binutils-dev_2.18.50.0.7-r13.1.6_armv7a.ipk

sudo opkg install /media/SDHC-OS/x-tchain/cpp_4.3.3-r23.1.6_armv7a.ipk
sudo opkg install /media/SDHC-OS/x-tchain/cpp-symlinks_4.3.3-r23.1.6_armv7a.ipk
sudo opkg install /media/SDHC-OS/x-tchain/g++_4.3.3-r23.1.6_armv7a.ipk
sudo opkg install /media/SDHC-OS/x-tchain/g++-symlinks_4.3.3-r23.1.6_armv7a.ipk
sudo opkg install /media/SDHC-OS/x-tchain/libstdc++-dev_4.3.3-r23.1.6_armv7a.ipk

sudo opkg install /media/SDHC-OS/x-tchain/libsdl-1.2-dev_1.2.14-r7.6_armv7a.ipk
sudo opkg install /media/SDHC-OS/x-tchain/libsdl-gfx-dev_2.0.17-r0.6_armv7a.ipk
sudo opkg install /media/SDHC-OS/x-tchain/libsdl-image-1.2-dev_1.2.10-r5.2.6_armv7a.ipk
sudo opkg install /media/SDHC-OS/x-tchain/libsdl-mixer-1.2-dev_1.2.11-r7.6_armv7a.ipk
sudo opkg install /media/SDHC-OS/x-tchain/libsdl-net-1.2-dev_1.2.7-r1.6_armv7a.ipk
sudo opkg install /media/SDHC-OS/x-tchain/libsdl-ttf-2.0-dev_2.0.9-r0.6_armv7a.ipk
sudo opkg install /media/SDHC-OS/x-tchain/vim-syntax_7.2-r8.3.6_armv7a.ipk

Hope this helps.
 
Last edited by a moderator:

Stuckie

Member
Joined
Apr 7, 2004
Messages
492
Age
35
Location
Tired, and sleeping in the basement...
Website
www.stuckieworld.net
Here's my boot sd ( with gcc et al installed on it. )
I've told the first-boot wizard to start up again and wiped out my own stuff, so you can create your own user but have all the dev tools pre installed ( or at least, the ones I installed at any rate! )

This looks like HF5 RC1, if you're wondering.

http://www.stuckiegamez.co.uk/apps/pandora/SimpleDev/zaxxon-premade-dev.tar.bz2

Just extract to an ext2/3 formatted SD card, stuff it in your first slot and away you go ( it's set to autoboot )
 

quartercast

Well-Known Member
Joined
Feb 13, 2007
Messages
1,551
Stuckie said:
Ahh, if it's the ncurses issue, I ran into that.. if you install libncurses5 from opkg it should be fine.

Isn't installing ncurses from the angstrom repo what causes the problem? Seems to be for me.
 
Last edited by a moderator:

Stuckie

Member
Joined
Apr 7, 2004
Messages
492
Age
35
Location
Tired, and sleeping in the basement...
Website
www.stuckieworld.net
No idea, though as has been pointed out, we've diverged a bit from mainline OE so it's a bit iffy in pulling anything in and expecting it to work.. either way, the boot sd that I'm using ( and provided above ) is fine as I've been prodding it for a while now.

Very much seems to be a "if it ain't broke, don't fix it" thing... ;)
 

mindlord

Notices Two Things
Joined
Mar 10, 2006
Messages
1,790
Location
In a cave.
Website
Visit site
I tried installing ncurses5 first this time and AWESOME everything works. Thanks to everyone for all the input. I do still hope that a Pandora specific repo does get fully developed, though.
 

sswam

Advanced Member
Joined
Dec 16, 2009
Messages
1,393
I did install gcc etc on hf5 a couple days ago, into a root overlay.
It was tricky, so I wrote it up on the wiki here (linked from Getting Started):

http://pandorawiki.org/Compile_directly_on_the_Pandora

I'm having fun trying to get my SDL+GL game to work with GLES on the Pandora!
The music is playing and it can clear the screen and swap buffers, that's all that's working as of yet.
 
Top