One Step Closer To Homebrew On Psp V2.0 :d


yaustar

UK GP32 & GP2X Owner
Joined
Oct 18, 2003
Messages
2,714
Location
UK
Website
Visit site
There is now a downgrader from 2.0 -> 1.5. Check out pspupdates for the news since I cant find it anywhere else at the moment.
 

Alpha2

Heroic Autobot
Joined
Feb 3, 2004
Messages
3,821
Age
48
Location
New York
Website
the-real-alpha2.com
I'm curious, not that I need a down grader personally, but would one be able to say that this may lead to 2.0 homebrew in the future? I mean I'd think aperson would hate to ave to keep climbing up and down the firmware ladder if they own a 1.52 or greater FW game.
 

V3X

Dance Pac-man. DANCE!!!!
Joined
Mar 10, 2004
Messages
739
Age
32
Location
sunbury, victoria, australia
Website
Visit site
yes, that would be annoying.

now that u mention that, i think ill get 2 psps, hopefully, lol.

hmmm. my bday commin up so me thinks i shall calls me mother.

if any of u wanna giv me a generous birthday present it'd be nice, lol!! :lol: :p :lol:
 

gary.mckeown

Member
Joined
Jul 12, 2004
Messages
367
Age
39
Location
U.K
Website
Visit site
so does this mean i can upgrade my 1.50 to 2.0 to try the web browser then downgrade it to 1.50 again and carry on using my umd emu?
 

razzy

Member
Joined
Feb 9, 2004
Messages
228
Age
50
Location
Ilfracombe Devon UK
Website
Visit site
gary.mckeown posted on Sep 28 2005 at 02:21 AM said:
so does this mean i can upgrade my 1.50 to 2.0 to try the web browser then downgrade it to 1.50 again and carry on using my umd emu?


From what i've read on their forums (PSP Updates) you can downgrade to a 1.5 then upgrade again to 2.0 without any problems so i think it should work in reverse.

Video of it here.
 
Last edited by a moderator:

gary.mckeown

Member
Joined
Jul 12, 2004
Messages
367
Age
39
Location
U.K
Website
Visit site
excellent i think i'll leave it a few days first and see if any problems show up then i'll upgrade to 2.0 and check that out.
 

Steve-O

Very Active Member
Joined
Aug 28, 2003
Messages
4,054
gary.mckeown posted on Sep 28 2005 at 03:07 AM said:
excellent i think i'll leave it a few days first and see if any problems show up then i'll upgrade to 2.0 and check that out.

same :)

but Im feeling like updating to 2.0 now to try 2.0 out :)
 
Last edited by a moderator:

Kop_007

Istanbul Red
Joined
Apr 11, 2003
Messages
1,152
Alpha2 posted on Sep 28 2005 at 01:31 AM said:
I mean I'd think aperson would hate to ave to keep climbing up and down the firmware ladder if they own a 1.52 or greater FW game.

WAAAAAAAAAAAB VERRRRRRRRRRRRRSIIIIIIIIIIION CHANGERRRRRRRRRR

It works, at least for now.
 
Last edited by a moderator:

gary.mckeown

Member
Joined
Jul 12, 2004
Messages
367
Age
39
Location
U.K
Website
Visit site
sony will bring out a new firmware in about 1month with something really enticing in it that will be hard to resist, like some sort of instant messenger like yahoo/msn/icq, that would be painfull lol

Gaz/
 

Alpha2

Heroic Autobot
Joined
Feb 3, 2004
Messages
3,821
Age
48
Location
New York
Website
the-real-alpha2.com
Yeah, Gamespot has already announced to the word that 2.0 has been cracked. So it's only a matter of a few weeks before Sony announces a hack-fixed FW 2.1. thus making yet anouther version to have to get around.

I can't tell if the Version changer comments are sarcastic or not. Yeah okay It's greate if you want to play a 1.52 game on a 1.5 machine you're good, but unless they update it to fool 2.0 it's not very useful. You'd have to version update to 2.0 to play GTA then back date to 1.5 and spoof to play Burnout and then update again to play GTA and so forth and so on... It's just a big hassle and after awhile this is just plain bound to eventually do something horrible to your PSP in my opinion.
 

gary.mckeown

Member
Joined
Jul 12, 2004
Messages
367
Age
39
Location
U.K
Website
Visit site
but a fw 2.1 will only bother people if there's something worth updating for. if they release it saying "fw2.1 stops you playing homebrew" then no ones going to update but if it says "fw2.1 includes messenger, voice chat, digital camera but stops you playing homebrew then a lot of people will update.
 
Joined
Oct 8, 2003
Messages
588
Age
37
Location
South wales, UK.
Website
Visit site
its a shame i have to replace my PSP since it has dead pixels, so i cant downgrade until i get my replacement.

is it dangerous to upgrade/downgrade as often as you like or will something screw up eventually?

o ye, some guy is already porting a messenger.. MSN if im not mistaken, i read about that a week or so ago, not sure where it was though :huh:
 

Kop_007

Istanbul Red
Joined
Apr 11, 2003
Messages
1,152
Alpha2 posted on Sep 28 2005 at 08:30 AM said:
I can't tell if the Version changer comments are sarcastic or not. Yeah okay It's greate if you want to play a 1.52 game on a 1.5 machine you're good, but unless they update it to fool 2.0 it's not very useful. You'd have to version update to 2.0 to play GTA then back date to 1.5 and spoof to play Burnout and then update again to play GTA and so forth and so on... It's just a big hassle and after awhile this is just plain bound to eventually do something horrible to your PSP in my opinion.

It does allow you to play 2.0 games. :D

Winning Eleven is a 2.0 game and it works.
:D
 
Last edited by a moderator:

V3X

Dance Pac-man. DANCE!!!!
Joined
Mar 10, 2004
Messages
739
Age
32
Location
sunbury, victoria, australia
Website
Visit site
Shadow of Chaos posted on Sep 28 2005 at 08:48 PM said:
its a shame i have to replace my PSP since it has dead pixels, so i cant downgrade until i get my replacement.

is it dangerous to upgrade/downgrade as often as you like or will something screw up eventually?

o ye, some guy is already porting a messenger.. MSN if im not mistaken, i read about that a week or so ago, not sure where it was though :huh:


im pretty sure its like the gp32 in tirms of "flashing' (if u will) the firmware.

btw, would this count as firmware flashing??
 
Last edited by a moderator:
Joined
Oct 8, 2003
Messages
588
Age
37
Location
South wales, UK.
Website
Visit site
I think i mean upgrading, i am used to the term "flashing" because of bios flashes on the pc :p .

So, if we can play 2.0 games on a 1.5 downgraded PSP, what happens when we want to play a infrastructure-multiplayer game online?.
 
Top