SGX driver installer (beta)


TrashyMG

Sarcasm Dispenser
Staff member
Joined
Jan 18, 2010
Messages
11,246
Looks like 4.10.00.01 doesn't play nice with new Mupen64plus.. but I suppose I was used to swapping SGX versions on the old version of Mupen anyway.
 

Michoko

Member
Joined
May 13, 2008
Messages
458
Location
France
Hi,

Is 4.10.00.01 supposed to appear even if you run the PND on a CC Pandora? I ran it on mine, and can't see the 4.10.00.01 entry in the list. Thanks!
 

Michoko

Member
Joined
May 13, 2008
Messages
458
Location
France
OK thank you. It seems that it's more and more frustrating those days to have a CC model, especially with the cool news regarding DC emulation ;)
 

elwing

Rabbit Addict
Joined
Feb 23, 2009
Messages
3,118
4.10.00.01 doesn't play nicely with PPSSPP too...

edit: Ok, just retested with a newer version of PPSSPP and it now runs with 4.10
 
Last edited by a moderator:

rohezal

Advanced Member
Joined
Oct 18, 2009
Messages
1,712
What driver do you recommend for using with a rebirth for most performance?

Will this driver work with mupen64 and reicast? Will it work with Jedi Knight 2?
 

mcobit

Advanced Member
Joined
Jul 28, 2008
Messages
6,910
They have a slightly newer sgx revision. Thats why Android 3D apps work better on them than on the CC units.
 

TrashyMG

Sarcasm Dispenser
Staff member
Joined
Jan 18, 2010
Messages
11,246
4.04.00.03 is the only one that works on my gigahertz edition, with the latest drivers (4.10.xxxxx) games don't start.
Are you updated to the latest Firmware (SZ 1.60) with all online updates?
 
Last edited by a moderator:

LTStone

Active Member
Joined
Feb 19, 2011
Messages
866
Age
48
would any of these drivers affect android or does android have is own drivers?
 

Erchitu

Still Fresh
Joined
Nov 28, 2013
Messages
21
Age
40
Location
Bitti, Sardegna, Italy
 Are you updated to the latest Firmware (SZ 1.60) with all online updates?
I have 1.60, but I haven't done any online update yet... I haven't checked. I tryed OpenArena, Jedi Accademy, Return To Castle Wolfenstein, Mupen64 etc... All is working good with that driver.
 

N3Cr0

Member
Joined
Mar 22, 2013
Messages
279
Is there a way to get the installer running on the OS booted from SD card?

I get the same error as enc_carlson.

Firmware is up-to-date (1.60)

I am having trouble running the pnd to install these drivers. Every time I try to run the pnd, it gives me this error message: "Mounting the PND failed. The application wont start. Please have a look at /tmp/pndrun_sgx_driver_installer.out". Here are the contents of that file:

ge=======================================================================================

PND : /media/mmcblk0p1/pandora/menu/sgx_drivers_r1.pnd

PND_FSTYPE : Squashfs

APPDATADIR : /media/mmcblk0p1/pandora/appdata/sgx_driver_installer

APPDD_FSTYPE : vfat

PND_CPUSPEED :

EXENAME : run.sh

ARGUMENTS :

=======================================================================================

[ START ]--- Mount the PND ----------

Mounting : mount -t squashfs -o ro "/dev/loop0" "/mnt/utmp/sgx_driver_installer"

mount: wrong fs type, bad option, bad superblock on /dev/loop0,

missing codepage or helper program, or other error

In some cases useful info is found in syslog - try

dmesg | tail or so

WARNING : mount faild, re-tring

mount: wrong fs type, bad option, bad superblock on /dev/loop0,

missing codepage or helper program, or other error

In some cases useful info is found in syslog - try

dmesg | tail or so

ERROR The PND File-system is not mounted !

+++++++

Loopback devices :

/dev/loop0: [b301]:157 (/media/mmcblk0p1/pandora/menu/sgx_drivers_r1.pnd)

Are mounted on :

For these Union :

ERROR: The Union File-system is not mounted !

+++++++

Loopback devices :

/dev/loop0: [b301]:157 (/media/mmcblk0p1/pandora/menu/sgx_drivers_r1.pnd)

Are mounted on :

For these Union :

[ FAILED]--- Mount the PND ----------

=======================================================================================

Return code is : 8
 
Last edited by a moderator:

N3Cr0

Member
Joined
Mar 22, 2013
Messages
279
I have downloaded the one in the first post (r2).

I shouldn't have said 'the same error', but a similar error.
 
Last edited by a moderator:
Top