Release Telegram

I will try a little bit too.
Acutaly i try to compile the latest Git FFmpeg and add into Codeblocks here.
After that i try to copy the newer and Libav Libs into the latest PND.

Before that i tried to compile the latest libgif but have Similar Error like:
yuv2rgb Error in some XML Things.
I should disable some Validations but had no Idea.

Maybe the hidden Error is on another Part?
@ingoreis : when you are in gdb, at the Bus error, can you try type "l" to get some code. It's asm code I'm looking for, I try to understand where the bus error happens.
Also, some "info reg" can be usefull.
I must do that later..sorry have Visitors here ;)
@ptitSeb here the Output :-D
(gdb) r
Starting program: /mnt/utmp/telegram/Telegram
warning: File "/lib/" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".
To enable execution of this file add
add-auto-load-safe-path /lib/
line to your configuration file "/mnt/utmp/telegram/home/.gdbinit".
To completely disable this security protection add
set auto-load safe-path /
line to your configuration file "/mnt/utmp/telegram/home/.gdbinit".
For more information about this security protection see the
"Auto-loading safe path" section in the GDB manual. E.g., run from the shell:
info "(gdb)Auto-loading safe path"
warning: Unable to find libthread_db matching inferior's thread library, thread debugging will not be available.
warning: File "/lib/" auto-loading has been declined by your `auto-load safe-path' set to "$debugdir:$datadir/auto-load".
warning: Unable to find libthread_db matching inferior's thread library, thread debugging will not be available.
Qt: gdb: -nograb added to command-line options.
Use the -dograb option to enforce grabbing.
[New LWP 19746]
Qt: Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
[New LWP 19747]
[New LWP 19748]
[New LWP 19749]
[New LWP 19752]
[New LWP 19753]
[New LWP 19754]
[LWP 19752 exited]
[New LWP 19755]
[New LWP 19756]
[New LWP 19757]
[LWP 19756 exited]
[New LWP 19758]
[New LWP 19759]
[New LWP 19760]
[New LWP 19761]
[LWP 19760 exited]
[New LWP 19762]
[New LWP 19763]
[New LWP 19764]
[LWP 19763 exited]
[New LWP 19765]
[New LWP 19766]
[New LWP 19767]
[LWP 19766 exited]
[LWP 19758 exited]
[New LWP 19768]
[New LWP 19769]
[swscaler @ 0x248f980] No accelerated colorspace conversion found from yuv420p to bgra.

Program received signal SIGBUS, Bus error.
[Switching to LWP 19769]
0x411bfaf0 in ff_yuv420p_to_bgra_neon () at libswscale/arm/yuv2rgb_neon.S:279
279 libswscale/arm/yuv2rgb_neon.S: No such file or directory.
(gdb) bt
#0 0x411bfaf0 in ff_yuv420p_to_bgra_neon ()
at libswscale/arm/yuv2rgb_neon.S:279
#1 0x00000000 in ?? ()
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
(gdb) i
"info" must be followed by the name of an info command.
List of info subcommands:

info address -- Describe where symbol SYM is stored
info all-registers -- List of all registers and their contents
info args -- Argument variables of current stack frame
info auto-load -- Print current status of auto-loaded files
info auxv -- Display the inferior's auxiliary vector
info bookmarks -- Status of user-settable bookmarks
info breakpoints -- Status of specified breakpoints (all user-settable breakpoints if no argument)
info checkpoints -- IDs of currently known checkpoints
info classes -- All Objective-C classes
info common -- Print out the values contained in a Fortran COMMON block
info copying -- Conditions for redistributing copies of GDB
info dcache -- Print information on the dcache performance
info display -- Expressions to display when program stops
info exceptions -- List all Ada exception names
info extensions -- All filename extensions associated with a source language
info files -- Names of targets and files being debugged
---Type <return> to continue, or q <return> to quit---l
info float -- Print the status of the floating point unit
info frame -- All about selected stack frame
info functions -- All function names
info guile -- Prefix command for Guile info displays
info handle -- What debugger does when program gets various signals
info inferiors -- IDs of specified inferiors (all inferiors if no argument)
info line -- Core addresses of the code for a source line
info locals -- Local variables of current stack frame
info macro -- Show the definition of MACRO
info macros -- Show the definitions of all macros at LINESPEC
info mem -- Memory region attributes
info os -- Show OS data ARG
info probes -- Show available static probes
info proc -- Show /proc process information about any running process
info program -- Execution status of the program
info record -- Info record options
info registers -- List of integer registers and their contents
info scope -- List the variables local to a scope
info selectors -- All Objective-C selectors
---Type <return> to continue, or q <return> to quit---return
info set -- Show all GDB settings
info sharedlibrary -- Status of loaded shared object libraries
info signals -- What debugger does when program gets various signals
info skip -- Display the status of skips
info source -- Information about the current source file
info sources -- Source files in the program
info stack -- Backtrace of the stack
info static-tracepoint-markers -- List target static tracepoints markers
info symbol -- Describe what symbol is at location ADDR
info target -- Names of targets and files being debugged
info tasks -- Provide information about all known Ada tasks
info terminal -- Print inferior's saved terminal status
info threads -- Display currently known threads
info tracepoints -- Status of specified tracepoints (all tracepoints if no argument)
info tvariables -- Status of trace state variables and their values
info types -- All type names
info variables -- All global and static variable names
info vector -- Print the status of the vector unit
---Type <return> to continue, or q <return> to quit---q
(gdb) info reg
r0 0x1e0 480
r1 0x124 292
r2 0x4f6b7008 1332441096
r3 0x780 1920
r4 0x22fcd00 36687104
r5 0x1e0 480
r6 0x23228f8 36841720
r7 0x23228f0 36841712
r8 0x1e0 480
r9 0x80 128
r10 0x232c038 36880440
r11 0x4f6b7788 1332443016
r12 0x22fced0 36687568
sp 0x4e9dea28 0x4e9dea28
lr 0x4119be51 1092206161
pc 0x411bfaf0 0x411bfaf0 <ff_yuv420p_to_bgra_neon+248>
cpsr 0x8000030 134217776

I have decided to hack ffmpeg and add a new environnement variable "FFMPEG_NO_NEON" that when set, inhibit all neon subroutine. I'm building a pnd now, it will be uploaded in an hour probably. This version should work (more slowly, but Telegram is not a movie player, so I don't think it matters much here).
[doublepost=1473000680,1472997351][/doublepost]Ok, new build is uploaded, still same link.
This build also have all debug info.
If you want to dbg it, do forget to add "FFMPEG_NO_NEON=1" before the "gdb..." to disable neon optim, and so probably avoid the bus error.
So much work and so many Hours for it... can i thank you for that?

ah i know..i press 1000x the Thank you Key on my Keyboard here :)
In the new version you just released. They just aren't visible. They can still be selected and copied and pasted.
For me it work fine here.
But i have CodeBlocks in Backround running.
I try to compile latest VLC Git here.
Smilies work fine here.

Yes without Codeblocks no Emoticons.
Last edited:
@ingoreis : then I need you to launch Telegram, with some emotcions visibles, with codeblocks launched, then from the codeblocks command line type
lsof | grep Telegram | grep codeblocks
and copy/paste the result here.
oh o tried to reproduce this but no i do not have the Emoticons more.
Maybe they whered saved in my Appdata..but i deleted the older Appdata before this and...whops no Emoticons more here :$

I will try tomorrow more.
Maybe i find that File and can send it to you.
Maybe i can extract this Emoticon File from an older Version.
But for Today i am too tired

pndrunout say nothing here.
New build on the repo, with updated sources (0.10.1). I also added a few optinal libs to the pnd, but no idea if this fixes the Emoji issue. Anyway, as I cannot test, I will probably not work on this issue.

Build 12

  • Updated to latest sources
  • Added a few libs